summaryrefslogtreecommitdiff
path: root/dev-python/pyblake2/pyblake2-0.9.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyblake2/pyblake2-0.9.3.ebuild')
-rw-r--r--dev-python/pyblake2/pyblake2-0.9.3.ebuild39
1 files changed, 28 insertions, 11 deletions
diff --git a/dev-python/pyblake2/pyblake2-0.9.3.ebuild b/dev-python/pyblake2/pyblake2-0.9.3.ebuild
index 10da95058c15..619cb27c3cf6 100644
--- a/dev-python/pyblake2/pyblake2-0.9.3.ebuild
+++ b/dev-python/pyblake2/pyblake2-0.9.3.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic toolchain-funcs
DESCRIPTION="BLAKE2 hash function extension module"
HOMEPAGE="https://github.com/dchest/pyblake2 https://pypi.python.org/pypi/pyblake2"
@@ -12,19 +12,36 @@ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="CC0-1.0"
SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_avx cpu_flags_x86_xop"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+blake2_impl() {
+ local code='
+#if defined(__XOP__)
+ HAVE_XOP
+#elif defined(__AVX__)
+ HAVE_AVX
+#elif defined(__SSSE3__)
+ HAVE_SSSE3
+#elif defined(__SSE2__)
+ HAVE_SSE2
+#endif
+'
+ local res=$($(tc-getCC) -E -P ${CFLAGS} - <<<"${code}")
+
+ case ${res} in
+ *HAVE_XOP*) echo XOP;;
+ # this does not actually do anything but implicitly enabled SSE4.1...
+ *HAVE_AVX*) echo AVX;;
+ *HAVE_SSSE3*) echo SSSE3;;
+ # note: SSE2 is 2.5x slower than pure REGS, so we ignore it
+ #*HAVE_SSE2*) echo SSE2;;
+ *) echo REGS;;
+ esac
+}
python_prepare_all() {
- local impl=REGS
- # note: SSE2 is 2.5x slower than pure REGS, so we ignore it
- use cpu_flags_x86_ssse3 && impl=SSSE3
- # this does not actually do anything but implicitly enabled SSE4.1...
- use cpu_flags_x86_avx && impl=AVX
- use cpu_flags_x86_xop && impl=XOP
-
# uncomment the implementation of choice
- sed -i -e "/BLAKE2_COMPRESS_${impl}/s:^#::" setup.py || die
+ sed -i -e "/BLAKE2_COMPRESS_$(blake2_impl)/s:^#::" setup.py || die
distutils-r1_python_prepare_all
}