summaryrefslogtreecommitdiff
path: root/dev-python/pyaudio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyaudio')
-rw-r--r--dev-python/pyaudio/Manifest1
-rw-r--r--dev-python/pyaudio/pyaudio-0.2.13-r2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyaudio/Manifest b/dev-python/pyaudio/Manifest
index eae139e1be2f..995348526b30 100644
--- a/dev-python/pyaudio/Manifest
+++ b/dev-python/pyaudio/Manifest
@@ -1,3 +1,4 @@
DIST PyAudio-0.2.13.tar.gz 46820 BLAKE2B f0c55f4d6d028ab1210c031b6a3808f93f7963a49cf54e4c9ae65bf936f218386d4a43322b9bd645233e6f881e3d15cdcc6ceeb7fe65fd287696048b206cbfbf SHA512 1ae453cae442118ae1b0db44ca8736621a361af3686e47561bffa0d43352039ed5f882412ca22a2a4320b362f966e727b0e38bb9706e99b85d99bc16cc943008
EBUILD pyaudio-0.2.13-r1.ebuild 1096 BLAKE2B cf460c24c2ec7003bc1d2a5584df69aae6d7163d531c964c0095538299ccf01b3ddb05132537bdc96ba8b762a346b28643e56e4fd8142a0e8d6b34d47b0a23da SHA512 6314618fa039fced96cc40974a8fbe26af1394c04ba38e899089f2a232e5df82a623f76dce093ede6b89a2b39fd264dc5e5b223404c114ee9d76ea1bc441f69c
+EBUILD pyaudio-0.2.13-r2.ebuild 1093 BLAKE2B 3055db6c57a1236346b8d4845a779acf3a4b7773126c15306b3efc1e2e2cbb769c6d75169c28f5402e79e31bd664274ed52228b006626b526cc41be9bf4fd54a SHA512 ff5331df820e8ca1d57d85b5f1fb305a21f381af5a5a6fca50fc8ee41b6fa305cf6caf0b52f5fd733b441561c9d23e0cf6fa0604d0bf6a8ffa28da660f21ca73
MISC metadata.xml 640 BLAKE2B 54eae253ef66fcdc9f69ff477374237c964b53b9b53a3d418a560bb2fa681ca438b81fcfccbd6cb6f16a4f2698adeb8ef9e9d203403e5750a157f1adfa3b0cb1 SHA512 b04e933cb7cfc59ea59dd9d8523fc34c05acada24c54fb5c9b5bf1fb7aee4c9b74848605d131a2d47d09b3a4ad3ca6d999e64848ef46aad0fd6a6757723df3b8
diff --git a/dev-python/pyaudio/pyaudio-0.2.13-r2.ebuild b/dev-python/pyaudio/pyaudio-0.2.13-r2.ebuild
new file mode 100644
index 000000000000..7332925125e3
--- /dev/null
+++ b/dev-python/pyaudio/pyaudio-0.2.13-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="PyAudio"
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517="setuptools"
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for PortAudio"
+HOMEPAGE="https://people.csail.mit.edu/hubert/pyaudio/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Tests work if you have the correct HW device(s) to test. 0.2.11-r1.
+RESTRICT="test"
+
+RDEPEND="media-libs/portaudio"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx sphinx
+distutils_enable_tests unittest
+
+python_test() {
+ elog "These tests require an OS loopback sound device that forwards audio"
+ elog "output, generated by PyAudio for playback, and forwards it to an input"
+ elog "device, which PyAudio can record and verify against a test signal."
+
+ cd tests || die
+ # pyaudio_tests have very complicated runtime requirements, therefore skipping them.
+ "${EPYTHON}" -m unittest error_tests -v || die "Tests fail with ${EPYTHON}"
+}