summaryrefslogtreecommitdiff
path: root/dev-python/pyasyncore
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyasyncore')
-rw-r--r--dev-python/pyasyncore/Manifest3
-rw-r--r--dev-python/pyasyncore/metadata.xml13
-rw-r--r--dev-python/pyasyncore/pyasyncore-1.0.4.ebuild24
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyasyncore/Manifest b/dev-python/pyasyncore/Manifest
new file mode 100644
index 000000000000..ea2fe7eea5a3
--- /dev/null
+++ b/dev-python/pyasyncore/Manifest
@@ -0,0 +1,3 @@
+DIST pyasyncore-1.0.4.tar.gz 15339 BLAKE2B 1cc689c94dc7fe4f4c75a78cf58a0afabbe48f01b8c1511f9500b93b64b862dc1c7cc653e17a49786af9360441fcb45be03fa38c72c2e89ec05385fd8bfc648a SHA512 43746fca009f7acc5f05506c7d54e71ee74a76a112c3689aa98ab714f0452d1ed1196836bf52585bbbced2d64c1d4ccd86f8f5c2d2c5537fdc397e29d0d87008
+EBUILD pyasyncore-1.0.4.ebuild 472 BLAKE2B 5fc176f6aa35848152b291e8f0c1a2c016dec6169397d0e168fddc7e5e35c4824422d81d9d676b092b28cbf27d485a9867d395a2f5b28839472aa291db2179bd SHA512 c46b6f4abfd67f9d73c4ddbbbcdb3d8c526032e72f8d30fb8cbdf1ce18e21b6b188ef7d8dd8216af687e0c65885b160ef968fc56d24d7dfb598dceb77cd5bce2
+MISC metadata.xml 410 BLAKE2B f69eeb55bd7570cb72b1dfc228c0ee3fd14bd4abd8b58d279c4672af0476ae1f84ee8c2aeb40208daa5a266479d881f5b8f7537da37af8118be2f16bdb21bb3f SHA512 71e37573484b24241176e588db3d9d0426db443555c15e258acf83a47fbd2158a5d6bc631bb5a58a4bc6d855a76f79361013ab08204293c95be6e0dfc3beef53
diff --git a/dev-python/pyasyncore/metadata.xml b/dev-python/pyasyncore/metadata.xml
new file mode 100644
index 000000000000..062106caae26
--- /dev/null
+++ b/dev-python/pyasyncore/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pyasyncore</remote-id>
+ <remote-id type="github">simonrob/pyasyncore</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyasyncore/pyasyncore-1.0.4.ebuild b/dev-python/pyasyncore/pyasyncore-1.0.4.ebuild
new file mode 100644
index 000000000000..e019b13f2aea
--- /dev/null
+++ b/dev-python/pyasyncore/pyasyncore-1.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_12 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Make asyncore available for Python 3.12 onwards"
+HOMEPAGE="
+ https://github.com/simonrob/pyasyncore
+ https://pypi.org/project/pyasyncore/
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+python_test() {
+ # Can't use d_e_t unittest (bug #926964)
+ eunittest tests
+}