summaryrefslogtreecommitdiff
path: root/dev-python/pyasn1/pyasn1-0.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyasn1/pyasn1-0.6.0.ebuild')
-rw-r--r--dev-python/pyasn1/pyasn1-0.6.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pyasn1/pyasn1-0.6.0.ebuild b/dev-python/pyasn1/pyasn1-0.6.0.ebuild
new file mode 100644
index 000000000000..01c2436b963e
--- /dev/null
+++ b/dev-python/pyasn1/pyasn1-0.6.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ASN.1 library for Python"
+HOMEPAGE="
+ https://pypi.org/project/pyasn1/
+ https://github.com/etingof/pyasn1/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx "docs/source"