summaryrefslogtreecommitdiff
path: root/dev-python/pyasn1-modules/pyasn1-modules-0.1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyasn1-modules/pyasn1-modules-0.1.5.ebuild')
-rw-r--r--dev-python/pyasn1-modules/pyasn1-modules-0.1.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyasn1-modules/pyasn1-modules-0.1.5.ebuild b/dev-python/pyasn1-modules/pyasn1-modules-0.1.5.ebuild
new file mode 100644
index 000000000000..6b4d97a374fb
--- /dev/null
+++ b/dev-python/pyasn1-modules/pyasn1-modules-0.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pyasn1 modules"
+HOMEPAGE="http://pyasn1.sourceforge.net/ https://pypi.python.org/pypi/pyasn1-modules"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=">=dev-python/pyasn1-0.3.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/${P}
+ doins -r tools
+}