summaryrefslogtreecommitdiff
path: root/dev-python/pyalsa/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyalsa/files')
-rw-r--r--dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch27
-rw-r--r--dev-python/pyalsa/files/pyalsa-1.2.7-python3.12.patch34
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch b/dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch
deleted file mode 100644
index 7f8cf6815d03..000000000000
--- a/dev-python/pyalsa/files/pyalsa-1.1.6-no-build-symlinks.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- pyalsa-1.1.6/setup.py
-+++ pyalsa-1.1.6/setup.py
-@@ -70,24 +70,3 @@
- 'alsamixer',
- 'alsaseq'
- ]
--
--uname = os.uname()
--dir = 'build/lib.%s-%s-%s/pyalsa' % (uname[0].lower(), uname[4], sys.version[:3])
--files = os.path.exists(dir) and os.listdir(dir) or []
--for f in SOFILES:
-- path = ''
-- for f2 in files:
-- if f2.startswith(f + '.') and f2.endswith('.so'):
-- path = dir + '/' + f2
-- break
-- if not path or not os.path.exists(path):
-- continue
-- p = 'pyalsa/%s.so' % f
-- print("%s -> %s" % (p, path))
-- try:
-- st = os.lstat(p)
-- if stat.S_ISLNK(st.st_mode):
-- os.remove(p)
-- except:
-- pass
-- os.symlink('../' + path, 'pyalsa/%s.so' % f)
diff --git a/dev-python/pyalsa/files/pyalsa-1.2.7-python3.12.patch b/dev-python/pyalsa/files/pyalsa-1.2.7-python3.12.patch
deleted file mode 100644
index f27a7714a986..000000000000
--- a/dev-python/pyalsa/files/pyalsa-1.2.7-python3.12.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-https://github.com/alsa-project/alsa-python/issues/9
-https://github.com/alsa-project/alsa-python/pull/10
-https://github.com/alsa-project/alsa-python/commit/cb75f5cdba0a29bdfa43eb56285da4917d2941a9
-
-From cb75f5cdba0a29bdfa43eb56285da4917d2941a9 Mon Sep 17 00:00:00 2001
-From: Francesco Ceruti <ceppofrancy@gmail.com>
-Date: Sat, 4 May 2024 22:16:16 +0200
-Subject: [PATCH] alsaseq: fix seg. fault when accessing `ConstantObject` extra
-
-Closes: https://github.com/alsa-project/alsa-python/pull/10
-Signed-off-by: Francesco Ceruti <ceppofrancy@gmail.com>
-Signed-off-by: Jaroslav Kysela <perex@perex.cz>
---- a/pyalsa/alsaseq.c
-+++ b/pyalsa/alsaseq.c
-@@ -353,18 +353,11 @@ typedef struct {
- } ConstantObject;
-
- #if PY_MAJOR_VERSION < 3
--/* PyInt is fixed size in Python 2 */
- # define CONST_VALUE(x) PyInt_AsLong((PyObject *)x)
--# define CONST_EXTRA(x) (&(x->extra))
- #else
--/* PyLong is variable size in Python 3 */
- # define CONST_VALUE(x) PyLong_AsLong((PyObject *)x)
--# define CONST_EXTRA(x) \
-- ((ConstantExtraFields *)( \
-- ((intptr_t)(&x->extra)) \
-- + abs(Py_SIZE(&x->base)) * Py_TYPE(x)->tp_itemsize \
-- ))
- #endif
-+# define CONST_EXTRA(x) (&(x->extra))
-
- /** alsaseq.Constant type (initialized later...) */
- static PyTypeObject ConstantType;