summaryrefslogtreecommitdiff
path: root/dev-python/pyacoustid
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyacoustid')
-rw-r--r--dev-python/pyacoustid/Manifest2
-rw-r--r--dev-python/pyacoustid/pyacoustid-1.2.2-r1.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pyacoustid/Manifest b/dev-python/pyacoustid/Manifest
index 75b28a6d1726..e4931894ce16 100644
--- a/dev-python/pyacoustid/Manifest
+++ b/dev-python/pyacoustid/Manifest
@@ -1,3 +1,5 @@
DIST pyacoustid-1.2.2.tar.gz 15869 BLAKE2B 01f327dd640819dd799f48b32e859fe39dccda3fd62714bf324c8219cf7053b36f1399793523634e9d4f3c6405bed5050abb34bdf53c72ff0ee22708fb57225a SHA512 5bcb3f017c3013eb8fc9e335540a1f5e6a52fc2fefa53d5ef246ba16e4ff615dd1d1cf08b5c80b1a38b149e0fa7dc0b15e4890dcc3f5478ef874b4ec22cf0813
+DIST pyacoustid-test.mp3 4507187 BLAKE2B 54494d9f23481f9d1ee77b136ac3e1790e9fb78c782159ad1793dbebf18f694e13f6413a8259bae84c789f73ea8241e590dbd7e30ccb7377b2afa946335da19b SHA512 faa582640e759322d4bd58d85f4aa7d3ef88fd90aa3c67c1390ba6d4c3213278c11fb60c8d6c87a25e82dffcc54986caa4f0e463acfbcd90993166577e5226d8
+EBUILD pyacoustid-1.2.2-r1.ebuild 1187 BLAKE2B 336c5082dc81bd0110080e9e11b8984c187d12203d94b323cae571163f2c0d4c5a6eabdf366fb23b35d516e22734ff0da29b3d6153265ec52d09f72d5fbce340 SHA512 542dfa358ee1480260b1e01edf934f248b24047ec667c8fea321e59c30f74892f0c188a95d545536d32d0816acd2c224982a079ca21439ebd8f7a824e771ac7d
EBUILD pyacoustid-1.2.2.ebuild 724 BLAKE2B a13a1d39173b49d6c4da9e67317c1679b214de2fae15f4e53c9262ba5dcbbd80434f3e44371b53902f8c33c4a2daa63b4edaa359873e93521338f49928860bc0 SHA512 87cf32244c3f9892dfbcaf5bd5bb0ec4b11c7d20f575ccf3791c80692952219c30eaa4968a7075bc0e58523d810de6e1486ba88687ddab45300be375f4e6c10c
MISC metadata.xml 714 BLAKE2B bc0db30cff6644da34b7944bec3d60b47f394ac854d547fcbbf3ee4d2719edc4cb781a42b3ab266fb7dfb5762679daaa0e382fd0fa8c2cffdd35af4cc55633be SHA512 6b6063bfe7d64d8a053c0e5c1609d8011e8aeeb265a895db88154e246761027ec2ba5fd582fb08b64e5ee09b3a238030415613df9267620936a718b76d6d1692
diff --git a/dev-python/pyacoustid/pyacoustid-1.2.2-r1.ebuild b/dev-python/pyacoustid/pyacoustid-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..0b0c3a8fd45f
--- /dev/null
+++ b/dev-python/pyacoustid/pyacoustid-1.2.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Chromaprint and the AcoustID web service"
+HOMEPAGE="https://pypi.org/project/pyacoustid/"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ test? (
+ https://s3.wasabisys.com/blocsonic/releases/maxblocs/bsmx0198/01-Follow_192kb.mp3
+ -> ${PN}-test.mp3
+ )
+"
+
+LICENSE="MIT test? ( CC-BY-SA-4.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+# Tests fail with network-sandbox, since they need to connect to acoustid.org
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/audioread[${PYTHON_USEDEP},ffmpeg]
+ dev-python/requests[${PYTHON_USEDEP}]
+ media-libs/chromaprint
+"
+
+python_test() {
+ # Working test will print the top metadata match from Acoustid's database.
+ "${EPYTHON}" aidmatch.py "${DISTDIR}/${PN}-test.mp3" || die "Test failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use examples ; then
+ docinto examples
+ dodoc aidmatch.py fpcalc.py
+ docompress -x /usr/share/doc/${PF}/examples/
+ fi
+}