summaryrefslogtreecommitdiff
path: root/dev-python/pyTenable/pyTenable-0.3.20.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyTenable/pyTenable-0.3.20.ebuild')
-rw-r--r--dev-python/pyTenable/pyTenable-0.3.20.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyTenable/pyTenable-0.3.20.ebuild b/dev-python/pyTenable/pyTenable-0.3.20.ebuild
new file mode 100644
index 000000000000..6aa15ef4bd9c
--- /dev/null
+++ b/dev-python/pyTenable/pyTenable-0.3.20.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2018 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tenable API Library for Tenable.io and SecurityCenter"
+HOMEPAGE="https://github.com/tenable/pyTenable"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.19[${PYTHON_USEDEP}]
+ >=dev-python/requests_pkcs12-1.3[${PYTHON_USEDEP}]
+ >=dev-python/semver-2.8.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+# requires networking and API endpoint
+RESTRICT="test"