summaryrefslogtreecommitdiff
path: root/dev-python/pyGPG/pyGPG-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyGPG/pyGPG-9999.ebuild')
-rw-r--r--dev-python/pyGPG/pyGPG-9999.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/dev-python/pyGPG/pyGPG-9999.ebuild b/dev-python/pyGPG/pyGPG-9999.ebuild
index 337db049369c..6749e63d1904 100644
--- a/dev-python/pyGPG/pyGPG-9999.ebuild
+++ b/dev-python/pyGPG/pyGPG-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9,10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -12,9 +12,12 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
EGIT_BRANCH="master"
+elif [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT="eb44ec69978044809325a0a9c8972d1d4f573b47"
+ SRC_URI="https://github.com/dol-sen/pyGPG/archive/${MY_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
else
SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
DESCRIPTION="A python interface wrapper for gnupg's gpg command"
@@ -22,9 +25,20 @@ HOMEPAGE="https://github.com/dol-sen/pyGPG"
LICENSE="BSD"
SLOT="0"
+if [[ ${PV} != *9999 ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
RDEPEND="app-crypt/gnupg"
+EPYTEST_DESELECT=(
+ # Expired keys
+ test/pyGPG/test_gpg.py::test_listkeys2
+ test/pyGPG/test_gpg.py::test_listkey2
+ test/pyGPG/test_gpg.py::test_listkey
+ test/pyGPG/test_gpg.py::test_fingerprint2
+)
+
distutils_enable_tests pytest
pkg_postinst() {