summaryrefslogtreecommitdiff
path: root/dev-python/pyGPG/pyGPG-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyGPG/pyGPG-0.2.ebuild')
-rw-r--r--dev-python/pyGPG/pyGPG-0.2.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/pyGPG/pyGPG-0.2.ebuild b/dev-python/pyGPG/pyGPG-0.2.ebuild
index a6a797b30f4d..e3d575a7cd70 100644
--- a/dev-python/pyGPG/pyGPG-0.2.ebuild
+++ b/dev-python/pyGPG/pyGPG-0.2.ebuild
@@ -1,24 +1,28 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-PYTHON_COMPAT=(python{2_7,3_5,3_6})
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1
-EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dol-sen/pyGPG.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
+fi
DESCRIPTION="A python interface wrapper for gnupg's gpg command"
HOMEPAGE="https://github.com/dol-sen/pyGPG"
-SRC_URI="https://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
IUSE=""
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86"
-
DEPEND=""
RDEPEND="${DEPEND}
app-crypt/gnupg