summaryrefslogtreecommitdiff
path: root/dev-python/pyClamd/pyClamd-0.4.0-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyClamd/pyClamd-0.4.0-r5.ebuild')
-rw-r--r--dev-python/pyClamd/pyClamd-0.4.0-r5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyClamd/pyClamd-0.4.0-r5.ebuild b/dev-python/pyClamd/pyClamd-0.4.0-r5.ebuild
new file mode 100644
index 000000000000..7d7dc6e7bb6d
--- /dev/null
+++ b/dev-python/pyClamd/pyClamd-0.4.0-r5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11,12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+PATCHES=( "${FILESDIR}/${P}-remove-obsolete-bugtrack_url.diff" )
+
+DESCRIPTION="python interface to Clamd (Clamav daemon)"
+HOMEPAGE="https://xael.org/pages/pyclamd-en.html"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+# Tests need clamd running and we cannot rely on that being
+# true during build
+RESTRICT="test"