summaryrefslogtreecommitdiff
path: root/dev-python/pweave/pweave-0.30.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pweave/pweave-0.30.3-r1.ebuild')
-rw-r--r--dev-python/pweave/pweave-0.30.3-r1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/dev-python/pweave/pweave-0.30.3-r1.ebuild b/dev-python/pweave/pweave-0.30.3-r1.ebuild
index 03a16a520ecf..fa40ea257494 100644
--- a/dev-python/pweave/pweave-0.30.3-r1.ebuild
+++ b/dev-python/pweave/pweave-0.30.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -16,6 +16,7 @@ DESCRIPTION="Scientific report generator and literate programming tool"
HOMEPAGE="http://mpastell.com/pweave/
https://github.com/mpastell/Pweave"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
IUSE="examples"
@@ -27,22 +28,23 @@ PATCHES=(
"${FILESDIR}/${P}-docs.patch"
"${FILESDIR}/${P}-rm-online-tests.patch" )
-RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
dev-python/ipykernel[${PYTHON_USEDEP}]
dev-python/jupyter_client[${PYTHON_USEDEP}]
dev-python/markdown[${PYTHON_USEDEP}]
dev-python/nbconvert[${PYTHON_USEDEP}]
dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]"
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
DEPEND="test? (
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
+ dev-python/scipy[${PYTHON_USEDEP}]
+)"
distutils_enable_sphinx doc/source dev-python/sphinx_rtd_theme
distutils_enable_tests pytest