summaryrefslogtreecommitdiff
path: root/dev-python/pure_eval/pure_eval-0.2.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pure_eval/pure_eval-0.2.1-r1.ebuild')
-rw-r--r--dev-python/pure_eval/pure_eval-0.2.1-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pure_eval/pure_eval-0.2.1-r1.ebuild b/dev-python/pure_eval/pure_eval-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..310d725f3a8c
--- /dev/null
+++ b/dev-python/pure_eval/pure_eval-0.2.1-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Safely evaluate AST nodes without side effects"
+HOMEPAGE="https://github.com/alexmojaki/pure_eval"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~riscv"
+
+BDEPEND="dev-python/wheel[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest