summaryrefslogtreecommitdiff
path: root/dev-python/pulsectl/pulsectl-22.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pulsectl/pulsectl-22.3.2.ebuild')
-rw-r--r--dev-python/pulsectl/pulsectl-22.3.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pulsectl/pulsectl-22.3.2.ebuild b/dev-python/pulsectl/pulsectl-22.3.2.ebuild
new file mode 100644
index 000000000000..1ac5a8b3118f
--- /dev/null
+++ b/dev-python/pulsectl/pulsectl-22.3.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
+HOMEPAGE="https://github.com/mk-fg/python-pulse-control"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-sound/pulseaudio"
+
+distutils_enable_tests unittest