summaryrefslogtreecommitdiff
path: root/dev-python/protobuf-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/protobuf-python')
-rw-r--r--dev-python/protobuf-python/Manifest4
-rw-r--r--dev-python/protobuf-python/protobuf-python-4.23.3.ebuild79
-rw-r--r--dev-python/protobuf-python/protobuf-python-9999.ebuild11
3 files changed, 87 insertions, 7 deletions
diff --git a/dev-python/protobuf-python/Manifest b/dev-python/protobuf-python/Manifest
index f51ac31c37f0..e5680106bfe5 100644
--- a/dev-python/protobuf-python/Manifest
+++ b/dev-python/protobuf-python/Manifest
@@ -1,5 +1,7 @@
AUX protobuf-python-3.20.3-python311.patch 3717 BLAKE2B f3a0b1b06bdbc2222fd3817b87f9b80cf609e9eb410770af31a069396eb68417f37c06603229ac8fc6aca958a9f8c0deec6b5f0812df6d7dac214b3f8622da29 SHA512 dd03b34b06e67aa4dc16281902e4676ee55169343d062b9515195ff9c92fc9cca4aaa24f83309b7f150f67a49356c41e22380bd68231dab7df04ac1c127f096f
DIST protobuf-21.9.tar.gz 5110670 BLAKE2B a4f5b7f58e1c5904ca990b100a72992f6f56177b28773f8de8c99e4158391d33cfb8aa8575915887fc9ae4294faf81d4ff6b470bc07b394bfd5885a09ba0fafe SHA512 6954b42d21921e630173b7848c056ab95635627d8eddec960f3db2ddda13eedde00520a9b350722e76e2998649eb8ebe10758e1db938b6a91e38ff3295b1b7c1
+DIST protobuf-23.3.tar.gz 5043803 BLAKE2B ee2edee230969555c9ef95069c7b1d6c23c3d1f8ea1b2249fb3e9f6fcf63312c6e10e9da65b80629fb08d5fb08d05a19bb9c752c25b892c1e3fd6f18b9279eb3 SHA512 646af367dbc61b42e322cf0b335f360e428b272e2b1f5361b2f17c18d3dc9dddd615e1279436028b1a42275a0beadda37c2c934fc27d6c892131cc8d526d8b3b
EBUILD protobuf-python-4.21.9.ebuild 1731 BLAKE2B 0c5584439d57d72eab538533be7a5033e60af36f1a4ed07b421351c56527c4b81ed88f9d6f207b4d174d26a828fd40936171ae8c03686b814b7666ed4ba19b37 SHA512 499d64a3c8b9bbbb60b823663feeb324a7103faf25a89848cb9db2b3835bd06ffcc486ed491646bc8e44154902c6419858d60cf779b3a2a955cb9a9ff60c0147
-EBUILD protobuf-python-9999.ebuild 1730 BLAKE2B e49453485911f97c493540bc19b4225120f90af5805a7ee794ff0f009889b9791b1e30fd86e0b6343afc5e99bfd6c8f0591185c06da80a0ed9e101555f27f862 SHA512 e68d2ee60559448705ab5d49cd59ac08574b218706db306010e23fddef5e96deb2d6d16b5479f3d448493a2c2c81a2066a3abe750de81e5f5040af83b65200f7
+EBUILD protobuf-python-4.23.3.ebuild 1673 BLAKE2B aa6f79dc14e913b1dc54f6aa93b6fc083c241e86399b65fa05d75e37f6dfc314ec94dc42438eee9da868cfe95d958d6501973d010dac702b37eeffa033770a8b SHA512 93fb7545331b07d9addce5e868c4c0582ced43eb1cd9cc471e29a8ea8fe3ab089d59c2f88742bd512d0431d892c3af810ed02f6a510b62dcdc5a4ca0ffaa8f5f
+EBUILD protobuf-python-9999.ebuild 1673 BLAKE2B aa6f79dc14e913b1dc54f6aa93b6fc083c241e86399b65fa05d75e37f6dfc314ec94dc42438eee9da868cfe95d958d6501973d010dac702b37eeffa033770a8b SHA512 93fb7545331b07d9addce5e868c4c0582ced43eb1cd9cc471e29a8ea8fe3ab089d59c2f88742bd512d0431d892c3af810ed02f6a510b62dcdc5a4ca0ffaa8f5f
MISC metadata.xml 594 BLAKE2B 433b449286cd4cc56adf2f920215ce22f9678052a5797e683adf7c7d58920ec95f6db81587c7f839458037dd8e61b1f655068e057feede8d4e5e394ff2adae3a SHA512 b1275564f5ee25ee71f49d8e8d04e0c90be2d2b5d590f49e775f6d8f5f842aa7745140e155cf85749efe820777db9a7630c8193c707ac360e49f9b05b8eba97a
diff --git a/dev-python/protobuf-python/protobuf-python-4.23.3.ebuild b/dev-python/protobuf-python/protobuf-python-4.23.3.ebuild
new file mode 100644
index 000000000000..ac61281fae8f
--- /dev/null
+++ b/dev-python/protobuf-python/protobuf-python-4.23.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 2008-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+PARENT_PN="${PN/-python/}"
+PARENT_PV="$(ver_cut 2-)"
+PARENT_P="${PARENT_PN}-${PARENT_PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/protocolbuffers/protobuf.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/protocolbuffers/protobuf/archive/v${PARENT_PV}.tar.gz
+ -> ${PARENT_P}.tar.gz
+ "
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+DESCRIPTION="Google's Protocol Buffers - Python bindings"
+HOMEPAGE="
+ https://developers.google.com/protocol-buffers/
+ https://pypi.org/project/protobuf/
+"
+
+LICENSE="BSD"
+SLOT="0/23.3.0"
+
+S="${WORKDIR}/${PARENT_P}/python"
+
+BDEPEND="
+"
+DEPEND="
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ ${BDEPEND}
+ dev-libs/protobuf:${SLOT}
+"
+
+distutils_enable_tests setup.py
+
+# Same than PATCHES but from repository's root directory,
+# please see function `python_prepare_all` below.
+# Simplier for users IMHO.
+PARENT_PATCHES=(
+)
+
+# Here for patches within "python/" subdirectory.
+PATCHES=(
+)
+
+python_prepare_all() {
+ pushd "${WORKDIR}/${PARENT_P}" > /dev/null || die
+ [[ -n "${PARENT_PATCHES[@]}" ]] && eapply "${PARENT_PATCHES[@]}"
+ eapply_user
+ popd > /dev/null || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ DISTUTILS_ARGS=( --cpp_implementation )
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}/install" -name "*.pth" -type f -delete || die
+}
diff --git a/dev-python/protobuf-python/protobuf-python-9999.ebuild b/dev-python/protobuf-python/protobuf-python-9999.ebuild
index 6e644110d77b..ac61281fae8f 100644
--- a/dev-python/protobuf-python/protobuf-python-9999.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-9999.ebuild
@@ -3,13 +3,14 @@
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
PARENT_PN="${PN/-python/}"
-PARENT_PV="${PV}"
+PARENT_PV="$(ver_cut 2-)"
PARENT_P="${PARENT_PN}-${PARENT_PV}"
if [[ "${PV}" == *9999 ]]; then
@@ -23,7 +24,7 @@ else
https://github.com/protocolbuffers/protobuf/archive/v${PARENT_PV}.tar.gz
-> ${PARENT_P}.tar.gz
"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
fi
DESCRIPTION="Google's Protocol Buffers - Python bindings"
@@ -33,20 +34,18 @@ HOMEPAGE="
"
LICENSE="BSD"
-SLOT="0/32"
+SLOT="0/23.3.0"
S="${WORKDIR}/${PARENT_P}/python"
BDEPEND="
- dev-libs/protobuf:${SLOT}
- dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="
${PYTHON_DEPS}
- dev-libs/protobuf:${SLOT}
"
RDEPEND="
${BDEPEND}
+ dev-libs/protobuf:${SLOT}
"
distutils_enable_tests setup.py