summaryrefslogtreecommitdiff
path: root/dev-python/protobuf-python/protobuf-python-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/protobuf-python/protobuf-python-9999.ebuild')
-rw-r--r--dev-python/protobuf-python/protobuf-python-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/protobuf-python/protobuf-python-9999.ebuild b/dev-python/protobuf-python/protobuf-python-9999.ebuild
index f47c4a98916d..6ea098fc2992 100644
--- a/dev-python/protobuf-python/protobuf-python-9999.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=(python{2_7,3_6,3_7,3_8})
+PYTHON_COMPAT=(python{2_7,3_6,3_7,3_8,3_9})
DISTUTILS_USE_SETUPTOOLS="manual"
inherit distutils-r1
@@ -23,7 +23,7 @@ else
fi
LICENSE="BSD"
-SLOT="0/23"
+SLOT="0/24"
KEYWORDS=""
IUSE=""
@@ -43,6 +43,12 @@ if [[ "${PV}" == "9999" ]]; then
EGIT_CHECKOUT_DIR="${WORKDIR}/protobuf-${PV}"
fi
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -e "/^[[:space:]]*setup_requires = \['wheel'\],$/d" -i setup.py || die
+}
+
python_configure_all() {
mydistutilsargs=(--cpp_implementation)
}