summaryrefslogtreecommitdiff
path: root/dev-python/protobuf-python/protobuf-python-5.27.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/protobuf-python/protobuf-python-5.27.2.ebuild')
-rw-r--r--dev-python/protobuf-python/protobuf-python-5.27.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/protobuf-python/protobuf-python-5.27.2.ebuild b/dev-python/protobuf-python/protobuf-python-5.27.2.ebuild
new file mode 100644
index 000000000000..b0d4a3ec76a7
--- /dev/null
+++ b/dev-python/protobuf-python/protobuf-python-5.27.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2008-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Default implementation currently is upb, which doesn't match dev-libs/protobuf
+# https://github.com/protocolbuffers/protobuf/blob/main/python/README.md#implementation-backends
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYPI_PN="protobuf"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google's Protocol Buffers - Python bindings"
+HOMEPAGE="
+ https://protobuf.dev/
+ https://pypi.org/project/protobuf/
+"
+
+# Rename sdist to avoid conflicts with dev-libs/protobuf
+SRC_URI="
+ $(pypi_sdist_url)
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1-3)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"