summaryrefslogtreecommitdiff
path: root/dev-python/proto-plus/proto-plus-1.24.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/proto-plus/proto-plus-1.24.0-r1.ebuild')
-rw-r--r--dev-python/proto-plus/proto-plus-1.24.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/proto-plus/proto-plus-1.24.0-r1.ebuild b/dev-python/proto-plus/proto-plus-1.24.0-r1.ebuild
new file mode 100644
index 000000000000..8a5dedc2161a
--- /dev/null
+++ b/dev-python/proto-plus/proto-plus-1.24.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=${PN}-python-${PV}
+DESCRIPTION="Beautiful, Pythonic protocol buffers"
+HOMEPAGE="
+ https://github.com/googleapis/proto-plus-python/
+ https://pypi.org/project/proto-plus/
+"
+SRC_URI="
+ https://github.com/googleapis/proto-plus-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm64 x86"
+
+RDEPEND="
+ <dev-python/protobuf-python-6[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/google-api-core-1.31.5[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}