summaryrefslogtreecommitdiff
path: root/dev-python/prettyprinter/prettyprinter-0.13.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/prettyprinter/prettyprinter-0.13.2.ebuild')
-rw-r--r--dev-python/prettyprinter/prettyprinter-0.13.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/prettyprinter/prettyprinter-0.13.2.ebuild b/dev-python/prettyprinter/prettyprinter-0.13.2.ebuild
new file mode 100644
index 000000000000..764017b849b3
--- /dev/null
+++ b/dev-python/prettyprinter/prettyprinter-0.13.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Syntax-highlighting, declarative and composable pretty printer"
+HOMEPAGE="https://github.com/tommikaikkonen/prettyprinter"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/colorful[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ find "${ED}" -name '*.pth' -delete || die
+}