summaryrefslogtreecommitdiff
path: root/dev-python/precis-i18n/precis-i18n-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/precis-i18n/precis-i18n-1.1.0.ebuild')
-rw-r--r--dev-python/precis-i18n/precis-i18n-1.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/precis-i18n/precis-i18n-1.1.0.ebuild b/dev-python/precis-i18n/precis-i18n-1.1.0.ebuild
new file mode 100644
index 000000000000..ba09e54a5f5c
--- /dev/null
+++ b/dev-python/precis-i18n/precis-i18n-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Internationalized Usernames and Passwords"
+HOMEPAGE="
+ https://github.com/byllyfish/precis_i18n/
+ https://pypi.org/project/precis-i18n/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s test
+}