summaryrefslogtreecommitdiff
path: root/dev-python/portend/portend-2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/portend/portend-2.2-r1.ebuild')
-rw-r--r--dev-python/portend/portend-2.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/portend/portend-2.2-r1.ebuild b/dev-python/portend/portend-2.2-r1.ebuild
new file mode 100644
index 000000000000..aa3d5f77db5e
--- /dev/null
+++ b/dev-python/portend/portend-2.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="TCP port monitoring utilities"
+HOMEPAGE="https://pypi.org/project/portend/ https://github.com/jaraco/portend"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/tempora-1.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die "tests failed under ${EPTYHON}"
+}