summaryrefslogtreecommitdiff
path: root/dev-python/polib/polib-1.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/polib/polib-1.1.1.ebuild')
-rw-r--r--dev-python/polib/polib-1.1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/polib/polib-1.1.1.ebuild b/dev-python/polib/polib-1.1.1.ebuild
new file mode 100644
index 000000000000..daf3ed9a7524
--- /dev/null
+++ b/dev-python/polib/polib-1.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
+HOMEPAGE="https://github.com/izimobil/polib https://polib.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 sparc x86"
+
+distutils_enable_sphinx docs
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.7-BE-test.patch
+)
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die "Tests failed under ${EPYTHON}"
+}