summaryrefslogtreecommitdiff
path: root/dev-python/poetry
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/poetry')
-rw-r--r--dev-python/poetry/Manifest2
-rw-r--r--dev-python/poetry/poetry-1.8.2.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/poetry/Manifest b/dev-python/poetry/Manifest
index 92be1cdac5f5..6792f1ee12c9 100644
--- a/dev-python/poetry/Manifest
+++ b/dev-python/poetry/Manifest
@@ -1,7 +1,9 @@
DIST poetry-1.7.1.tar.gz 1483927 BLAKE2B d32f84cbed6f895678fba723700504cafe2bb7b1de0be0f289c0606b3c775d02e4172d74aafe58f29f9e2b5b9cb0f614b902bb9efa55ab1077a6689a8b4d331f SHA512 bf3654e9de71da35d7adfc239797dbed9813a2a1bb585b0bd9ad398706ad1628430422d0ebe7d9c3dcc1f619ad1a1a2073e9d9d3296354bf2f14a1aed5a5444e
DIST poetry-1.8.0.tar.gz 1514968 BLAKE2B 6ef6b8db6cd32c3c8d9a0759ebbfcfd4fafd79a4d236a5f48d7d1abc2d31bd93ee00686bf3623c5fbec212001dc1f2c4afce41f660b1404c39ad04815d364275 SHA512 ef2b3c6ea66d1d565ba8e17f0e4210e4406c08dd2d947deed85eb667ebfd618c3148ee0b67b5b2a020c7ddfb3fc692859de19e421c449954019d7a4b7942dd3d
DIST poetry-1.8.1.tar.gz 1514978 BLAKE2B 663b4db56e3a78a156c6f90eb2c34160c3d9a4f37762ff9df8826aabb59ba2d297f60c19a260e91bf34b40717a577fbfbd3fe9f4dc1ad9ca635a3c552da633a5 SHA512 b0d1240bdf20e46cc152e128351a4ed1b2aea86bd34a0edba662c6be403535bcf7339fdb2670807e6294f3043d2dd6296d085c03abccfd1c2c89216ddefe093b
+DIST poetry-1.8.2.tar.gz 1516966 BLAKE2B 6ca39b426a4117d0c2c3f12b9151d621d629f746e51ca77cda8d7f67ae2493ea9ecb7dd02f69cad3f346579fc3bb16b1117c0dad0a148763bb439c35eac673a5 SHA512 0151c264c2f353753ab7c5a248cdd30e60e33505fd915d841e789a37b18cc06f28b4f987144cd3dbf915e23f6947f6b17cb8fa316b34ce866b6b3559e73b8ddc
EBUILD poetry-1.7.1.ebuild 3266 BLAKE2B f58064bb0021b5d1616ef080090dfd8422d613260518049a2a1336e38927e633867d6f08e996eef6a550471769bc868699cdcdf6ae5fc0ab25faf6f73c857628 SHA512 236377b52df91550025c26817831cd8365b385bab5117f2dc635e4e2cc7df4b25f8e40f87b4de4757ee672f328c4d1ba7175f987b09648726dd1377ae1aa5854
EBUILD poetry-1.8.0.ebuild 3586 BLAKE2B 0b7bda7bff91ba09169bb962915443284427e185f4ef6d97745aba87e2e7d9b139a4b40e34a7cf24b04be47cc6260ee4a65c824d0b101adb8ac57ee4785f261a SHA512 a6ab1b9338c07edfff1354fad2914090ea4dcd3a7493c087e7c642e3f342c92feb785e60d12d0e22d0529f954f74dcc29b9df3ed341e1a6e62d8e476f9134302
EBUILD poetry-1.8.1.ebuild 3586 BLAKE2B b103c2f94b42f3dcfa88a72ef48e5daecc6f1c74f9b780f9af2ee3d6ecbce3a4ef94ec816b401e5a45af29af8a86b4f5d4d0332f5c469d9b1577730cdbf3f06d SHA512 adec5bb43d9bfeaccb0549e24465ac9361ce2b39a19ad4b018b60bb0aa281d870192979ab6aa3f97cb845791646357c4b7565f60983236e4c9416ab9bafc0168
+EBUILD poetry-1.8.2.ebuild 3586 BLAKE2B b103c2f94b42f3dcfa88a72ef48e5daecc6f1c74f9b780f9af2ee3d6ecbce3a4ef94ec816b401e5a45af29af8a86b4f5d4d0332f5c469d9b1577730cdbf3f06d SHA512 adec5bb43d9bfeaccb0549e24465ac9361ce2b39a19ad4b018b60bb0aa281d870192979ab6aa3f97cb845791646357c4b7565f60983236e4c9416ab9bafc0168
MISC metadata.xml 486 BLAKE2B 7757afe2f964f49a04a600ec80af8511387c3a80105c9050755e1815cac148734f540e4da8c1da401c15a63bf5d0a8200ed6a5e1c09e5dacc7d39f5f59dd343f SHA512 541063e55b4dc5b927ef4ff6b385663bbf978d13ac6644c2537483ec42f211780cab4d881b159894dfe86519b4655c80bcfe17cdb90a2e033077b390a3842f46
diff --git a/dev-python/poetry/poetry-1.8.2.ebuild b/dev-python/poetry/poetry-1.8.2.ebuild
new file mode 100644
index 000000000000..5126c1214c1c
--- /dev/null
+++ b/dev-python/poetry/poetry-1.8.2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A frontend for poetry - a python dependency management and packaging tool"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry
+ https://pypi.org/project/poetry/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# dev-python/build: 1.0 breaks backward compatibility
+# https://github.com/python-poetry/poetry/issues/8434
+RDEPEND="
+ >=dev-python/poetry-core-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/poetry-plugin-export-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/build-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/cachecontrol-0.14.0[${PYTHON_USEDEP}]
+ >=dev-python/cleo-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/crashtest-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.21.2[${PYTHON_USEDEP}]
+ >=dev-python/fastjsonschema-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/installer-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/keyring-24.0.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ >=dev-python/pexpect-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/shellingham-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+ >=dev-python/trove-classifiers-2022.5.19[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.23.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/deepdiff-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # unpin
+ sed -e 's:\^:>=:' \
+ -e '/poetry-core/s:":">=:' \
+ -e 's:,<[0-9.]*::' \
+ -i pyproject.toml || die
+
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Tests require network (they run `pip install ...`)
+ tests/installation/test_chef.py::test_isolated_env_install_success
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_directories
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_git
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_git_with_subdirectories
+ tests/installation/test_executor.py::test_executor_should_write_pep610_url_references_for_non_wheel_files
+ tests/installation/test_installer.py::test_installer_with_pypi_repository
+ tests/installation/test_pip_installer.py::test_uninstall_git_package_nspkg_pth_cleanup
+ tests/masonry/builders/test_editable_builder.py::test_builder_setup_generation_runs_with_pip_editable
+
+ # Works with network, but otherwise: Backend 'poetry.core.masonry.api' is not available.
+ tests/installation/test_chef.py::test_prepare_sdist
+ tests/installation/test_chef.py::test_prepare_directory
+ tests/installation/test_chef.py::test_prepare_directory_with_extensions
+ tests/installation/test_chef.py::test_prepare_directory_editable
+
+ # Internal test for lockfile being up-to-date
+ # Meaningless, also sdist does not include lockfile
+ tests/installation/test_installer.py::test_not_fresh_lock
+
+ # TODO
+ tests/installation/test_executor.py::test_executor_known_hashes
+ tests/utils/env/test_env_manager.py::test_create_venv_finds_no_python_executable
+)
+
+distutils_enable_tests pytest