summaryrefslogtreecommitdiff
path: root/dev-python/podman-py
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/podman-py')
-rw-r--r--dev-python/podman-py/Manifest2
-rw-r--r--dev-python/podman-py/podman-py-4.2.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/podman-py/Manifest b/dev-python/podman-py/Manifest
index 0613c58498ae..a170d40c3fc9 100644
--- a/dev-python/podman-py/Manifest
+++ b/dev-python/podman-py/Manifest
@@ -1,3 +1,5 @@
DIST podman-py-4.0.0.tar.gz 172208 BLAKE2B 79e153c9b8e064398f31ad270d0f84f1bcc8ba830d4240914004c5d4eb1fffa32496c5e88b8191b074b521510e2bf0b8ea211a481af8a0ba70e7b0d6c26efe10 SHA512 e1dd48c931871206aae11fbcc31a711eecda89e9c60f62d5616dc3219e073d3ba74d38f63a05d4688e97fb678d2e03f8cd883456f7e75f2d7e313aa859ca3e8f
+DIST podman-py-4.2.0.gh.tar.gz 176692 BLAKE2B 62692fc8e7eea0f05ef6a0743f85d5d3f4beb2029d042b746bdf164737f7b9bf1e6ba199a654eb62f75af5a2949ba27f90657e9f134b3b7576f7ebc1916b9f59 SHA512 8ff46c3201bb7f109075a01db57a96ad60246d6ed8962c7f86c0395887de67236dc0d022cedd807766a2a3714a822d620b3e1e0a2c9304156eaecfdbc06928dd
EBUILD podman-py-4.0.0.ebuild 1043 BLAKE2B c0bcf07a8edd5cf477b96573f7cc3391aef6e0c110bb0385080b9b18763be6bffae2aca050b664c29ea5e9add7046ba593b3212ad68db3d292a2d11182188083 SHA512 cdb128ad8c28758e114df16fd7be45fc05f38860e2d3732e5eb7fceeebd7e3b378f5e34bc1515d17d31df7a1727ea561f5b84b189a92e85d4da072e007956809
+EBUILD podman-py-4.2.0.ebuild 1051 BLAKE2B 014a913a64a2b3528748563695c7a4f5ae7e33b460088dcbc81c721742e798295869abf397c95f9195bb5280fe7f71f111c639559f5a4466541aa16845e1956e SHA512 2877462dd18ff18842d4a7b3a4f471f54b9a266e62c5503da79f9e7a1896f4a3692e219e8a769e55bfb004b593e9379bbc2f48b4edf10eb9bed4cd0d5661310e
MISC metadata.xml 475 BLAKE2B 42fc2c044df94ebf8a4eb5088a39ad3075089cd5a007473db0964df4efb8c7a437c94db9c161d6ba81d2c017377919861f17b7fe3e133aa597312cad2df012f4 SHA512 017f54ebf56fc59c14ff0e9c2f15b899556ff3d512d22ed2abc35227c079ec64c8eb855f60e65299abd7f8b5433b2268dc7c2e428476efc334e24f0d90181bc8
diff --git a/dev-python/podman-py/podman-py-4.2.0.ebuild b/dev-python/podman-py/podman-py-4.2.0.ebuild
new file mode 100644
index 000000000000..e10d9c77c179
--- /dev/null
+++ b/dev-python/podman-py/podman-py-4.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to interact with a Podman server"
+HOMEPAGE="
+ https://github.com/containers/podman-py/
+ https://pypi.org/project/podman/
+"
+SRC_URI="
+ https://github.com/containers/podman-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.2[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.24.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
+ )
+
+ # integration tests require a workable podman server,
+ # and it doesn't seem to work in ebuild env
+ epytest podman/tests/unit
+}