summaryrefslogtreecommitdiff
path: root/dev-python/pocketlint/pocketlint-0.25.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pocketlint/pocketlint-0.25.ebuild')
-rw-r--r--dev-python/pocketlint/pocketlint-0.25.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pocketlint/pocketlint-0.25.ebuild b/dev-python/pocketlint/pocketlint-0.25.ebuild
new file mode 100644
index 000000000000..c3bc7b176957
--- /dev/null
+++ b/dev-python/pocketlint/pocketlint-0.25.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Shared code for running pylint against rhinstaller projects"
+HOMEPAGE="
+ https://github.com/rhinstaller/pocketlint/
+ https://pypi.org/project/pocketlint/
+"
+SRC_URI="
+ https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" tests/pylint/runpylint.py || die "test failed with ${EPYTHON}"
+}