summaryrefslogtreecommitdiff
path: root/dev-python/pocketlint/pocketlint-0.24.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pocketlint/pocketlint-0.24.ebuild')
-rw-r--r--dev-python/pocketlint/pocketlint-0.24.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pocketlint/pocketlint-0.24.ebuild b/dev-python/pocketlint/pocketlint-0.24.ebuild
index c546d6ff289a..6aacc9d7bff0 100644
--- a/dev-python/pocketlint/pocketlint-0.24.ebuild
+++ b/dev-python/pocketlint/pocketlint-0.24.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -26,3 +26,7 @@ RDEPEND="
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/pylint[${PYTHON_USEDEP}]
"
+
+python_test() {
+ "${EPYTHON}" tests/pylint/runpylint.py || die "test failed with ${EPYTHON}"
+}