summaryrefslogtreecommitdiff
path: root/dev-python/plumbum
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/plumbum')
-rw-r--r--dev-python/plumbum/Manifest3
-rw-r--r--dev-python/plumbum/files/plumbum-1.7.0-test.patch34
-rw-r--r--dev-python/plumbum/plumbum-1.7.0-r1.ebuild43
3 files changed, 29 insertions, 51 deletions
diff --git a/dev-python/plumbum/Manifest b/dev-python/plumbum/Manifest
index 4dcc345b1e0f..2165e9c42705 100644
--- a/dev-python/plumbum/Manifest
+++ b/dev-python/plumbum/Manifest
@@ -1,4 +1,3 @@
-AUX plumbum-1.7.0-test.patch 1434 BLAKE2B 1b857261671912f2f708dae0b3aad50cd0d406697b451e31c314d8da931a279c8cfe2ccc80459b93b8f4c32ec7bb6c858c81014e6081719812eb76f8f64f79a3 SHA512 bec0051177757f09dcd53f9b6ed95ef83892c28a6e72e18acfda2e01c64660975d3fd3e82542a574f036cb48582325a8ad628ac6dc9d19d8e2780ba50c617015
DIST plumbum-1.7.0.tar.gz 318890 BLAKE2B 19ae8a37dff38ac3d263d9400e44ac174c46ff8cef92cf45b9ea31d6d344543fba66de3fd0fcd15acc205af5939f11be6c56e6cd9ca39a666f92f18dcd29b9f7 SHA512 0a12891278c12bb98b8bbb825448375240ee347eb3ca166b9cbb4da3e083979d947a7bf0a843fd9a0b7c9a13d09f24e988ee877f29420a3f29f40e387eec8826
-EBUILD plumbum-1.7.0-r1.ebuild 1398 BLAKE2B 52e1bb4732eaba2b638c983580ff2309473584021ed68dccc12671f084e63c8b593292a8de5d75e033b7bd368add46f9b737880b6d3572c9126e7de5aa06fa72 SHA512 2af14ce9b771ca57afa8f2c79d6b0cb7a7ddafd7058616ea2075cf1d754ce9be0e80341225a7947416831ad6ba69f62d2825ce33969f7e6a36df83dbe5e7f8a0
+EBUILD plumbum-1.7.0-r1.ebuild 1339 BLAKE2B 5d257b5e20813428799747fab22f7778e319db1f377db8ca7dea92dc640a5ba52503e9d98941b15bb3ddbcbad1e0349145a4e0832817234d13d43eb7dd4786d9 SHA512 565c0ef4252bc782a074fec930256519bdea3e088a64c3b4afb6326e35bdebeae724a0287b5568461a0d1cbf008f7148a6a4508c2f54117da7eadf5f43c46635
MISC metadata.xml 753 BLAKE2B c3723646f700efe4448d60c83c7b636db5b618076e6baba2201ab84f7f55953626df54c6d9b7ee368420ee4e94605b5e0129bb4e40bd412c7737a987c8aa0cd2 SHA512 5d1ce42aef769e6681ba77cf4f8f493697f9ec20cd648ce68ace94be9d6b022144e558f222a9950966b8d0e3e2c0297438e174ea02e3ce329c038e58c9573490
diff --git a/dev-python/plumbum/files/plumbum-1.7.0-test.patch b/dev-python/plumbum/files/plumbum-1.7.0-test.patch
deleted file mode 100644
index a79c5f67d18a..000000000000
--- a/dev-python/plumbum/files/plumbum-1.7.0-test.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -r -U2 plumbum-1.7.0.orig/setup.cfg plumbum-1.7.0/setup.cfg
---- plumbum-1.7.0.orig/setup.cfg 2021-02-09 02:46:57.071159800 +0700
-+++ plumbum-1.7.0/setup.cfg 2021-03-15 15:51:13.873287602 +0700
-@@ -66,5 +66,4 @@
-
- [tool:pytest]
--addopts = -v -ra --cov-config=setup.cfg
- norecursedirs = examples experiments
- timeout = 300
-diff -r -U2 plumbum-1.7.0.orig/tests/test_env.py plumbum-1.7.0/tests/test_env.py
---- plumbum-1.7.0.orig/tests/test_env.py 2021-02-09 02:46:46.000000000 +0700
-+++ plumbum-1.7.0/tests/test_env.py 2021-03-15 15:50:18.943289430 +0700
-@@ -14,4 +14,5 @@
- @skip_on_windows
- class TestEnv:
-+ @pytest.mark.skip("Something wrong here")
- def test_change_env(self):
- with local.env(silly=12):
-@@ -23,4 +24,5 @@
- assert len(local.env) == len(actual)
-
-+ @pytest.mark.skip("Something wrong here")
- def test_dictlike(self):
- keys = {x.split("=")[0] for x in printenv().splitlines() if "=" in x}
-diff -r -U2 plumbum-1.7.0.orig/tests/test_local.py plumbum-1.7.0/tests/test_local.py
---- plumbum-1.7.0.orig/tests/test_local.py 2021-02-09 02:46:46.000000000 +0700
-+++ plumbum-1.7.0/tests/test_local.py 2021-03-15 15:50:18.943289430 +0700
-@@ -168,5 +168,5 @@
- assert parts == ("/", "some", "long", "path", "to", "file.txt")
-
-- @pytest.mark.usefixtures("testdir")
-+ @pytest.mark.skip("Something wrong here")
- def test_iterdir(self):
- cwd = local.path(".")
diff --git a/dev-python/plumbum/plumbum-1.7.0-r1.ebuild b/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
index 1efb1bb5f04e..09603ad72375 100644
--- a/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
+++ b/dev-python/plumbum/plumbum-1.7.0-r1.ebuild
@@ -2,33 +2,46 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 optfeature
DESCRIPTION="A library for shell script-like programs in python"
HOMEPAGE="https://plumbum.readthedocs.io/en/latest/ https://github.com/tomerfiliba/plumbum"
-SRC_URI="https://files.pythonhosted.org/packages/ed/ba/431d7f420cd93c4b8ccb15ed8f1c6c76c81965634fd70345af0b19c2b7bc/${P}.tar.gz"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}] )"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-PATCHES=( "${FILESDIR}"/${PN}-1.7.0-test.patch )
+
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
distutils_enable_tests pytest
src_prepare() {
+ sed -e '/addopts/d' -i setup.cfg || die
distutils-r1_src_prepare
+}
- # Need sshd running
- rm tests/test_remote.py || die "rm test_remote.py failed"
- rm tests/test_utils.py || die "rm test_utils.py failed"
- rm tests/_test_paramiko.py || die "rm _test_paramiko.py failed"
- # Windows specific
- rm tests/test_putty.py || die "rm test_putty.py failed"
- # Needs sudo without password
- rm tests/test_sudo.py || die "rm test_sudo.py failed"
+python_test() {
+ local deselect=(
+ # Need sshd running
+ tests/test_remote.py
+ tests/test_utils.py
+ # Windows specific
+ tests/test_putty.py
+ # Needs sudo without password
+ tests/test_sudo.py
+ # Wrong assumptions about env handling
+ tests/test_env.py::TestEnv::test_change_env
+ tests/test_env.py::TestEnv::test_dictlike
+ tests/test_local.py::TestLocalPath::test_iterdir
+ )
+ epytest ${deselect[@]/#/--deselect }
}
pkg_postinst() {