summaryrefslogtreecommitdiff
path: root/dev-python/plumbum
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/plumbum')
-rw-r--r--dev-python/plumbum/Manifest2
-rw-r--r--dev-python/plumbum/plumbum-1.8.1.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/plumbum/Manifest b/dev-python/plumbum/Manifest
index 3b712c6f6eb9..04e8830fd930 100644
--- a/dev-python/plumbum/Manifest
+++ b/dev-python/plumbum/Manifest
@@ -1,3 +1,5 @@
DIST plumbum-1.8.0.tar.gz 325060 BLAKE2B 30006fa3826bbdd9482592d825931fd7dcb05b2aca6d762093c4f722f0426aaa6f07fde55754f115e4fba4a45997d2995a657c5a1cfa34c417bb4f5fb2e5834d SHA512 47874c42081d385fad85b9073fbeb711112b8fa847fc79035be1277a1fdabcfb06e7822a4dbba271d86502b9b297a70742f30b1158c363b668a47e783c9990cd
+DIST plumbum-1.8.1.tar.gz 316432 BLAKE2B 91288c5f793b9e3e7d1e1d3724f5cc16989d604b1236438fc71283fab5aa59bb34f1742fe2d79b7a9220e09a3622f5145769497765f3f9213dc70960af478fa0 SHA512 80031c07be3b68767556bba8246e964c51b16336d6105ad3d51d62f7c39287af6f928be713171c8c22cdd37145a0e7c3bd65d44f14bf8b1bc62483b648f3acff
EBUILD plumbum-1.8.0.ebuild 1354 BLAKE2B 9141a3ee5b1a2c6fe5a4981c986a911026df7a0a69e524c55e37c315bf2fa5b64600eef458141be122f97f1f310f1ca3a56b1c03b9fcf04c4cfda183cf6affa1 SHA512 be90b82291e43da729897cdcdd9d0efb84d8cd4abdb325d83334315fe4c333c0283ea08af374693676877b031bab28718e250ddd33041d5177353822a909255f
+EBUILD plumbum-1.8.1.ebuild 1435 BLAKE2B 2af0aa42040f22d3c6eeb3e2d44260bf61e7fb713010d113ecda3dd9aff151b7e79fe87b6a86724bbe7bb75c7fffaa7aba519967f43d805e7ba9b31197cd17c0 SHA512 c1cd67979f076dd4a3e38cabe1122aa1a98bdc5e79f2e688b78daaab2241fe6bbc155cad27ba953b0ba858c88adf2122935cd96f51aa12fec458d8bdb87f5d56
MISC metadata.xml 754 BLAKE2B b6d00fe0747da15445953a29abdd6f14112d02f2162746992f2fca80a321cd10f3cad40294e4bdbcf3f04d432b4d81902667296a0a5b8f99da2df2a5c58b18c1 SHA512 fbadbb7e5edd1573994cfc843e4a254ae5d12be5a3372f4fb061647983e360c2b0ea4a9e41ea8c9ff26028db75ad9cd5de881b8fdd9bf35864442e215aa42175
diff --git a/dev-python/plumbum/plumbum-1.8.1.ebuild b/dev-python/plumbum/plumbum-1.8.1.ebuild
new file mode 100644
index 000000000000..b7405c89ed31
--- /dev/null
+++ b/dev-python/plumbum/plumbum-1.8.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A library for shell script-like programs in python"
+HOMEPAGE="
+ https://plumbum.readthedocs.io/en/latest/
+ https://github.com/tomerfiliba/plumbum/
+ https://pypi.org/project/plumbum/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Need sshd running
+ tests/test_remote.py
+ tests/test_utils.py
+ # Windows specific
+ tests/test_putty.py
+ # Needs sudo without password
+ tests/test_sudo.py
+ # Wrong assumptions about env handling
+ tests/test_env.py::TestEnv::test_change_env
+ tests/test_env.py::TestEnv::test_dictlike
+ tests/test_local.py::TestLocalPath::test_iterdir
+)
+
+src_prepare() {
+ sed -e '/addopts/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ optfeature "remote commands via ssh" dev-python/paramiko
+ optfeature "progress bars in jupyter" dev-python/ipywidgets
+ optfeature "colored output in jupyter" dev-python/ipython
+ optfeature "images on the command line" dev-python/pillow
+}