summaryrefslogtreecommitdiff
path: root/dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild')
-rw-r--r--dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild b/dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..7b3d8dd18f94
--- /dev/null
+++ b/dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Support library for building plugins sytems in Python"
+HOMEPAGE="https://github.com/mitsuhiko/pluginbase"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}