summaryrefslogtreecommitdiff
path: root/dev-python/plette/plette-0.4.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/plette/plette-0.4.4.ebuild')
-rw-r--r--dev-python/plette/plette-0.4.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/plette/plette-0.4.4.ebuild b/dev-python/plette/plette-0.4.4.ebuild
new file mode 100644
index 000000000000..5a6f62b698a8
--- /dev/null
+++ b/dev-python/plette/plette-0.4.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Structured Pipfile and Pipfile.lock models"
+HOMEPAGE="
+ https://github.com/sarugaku/plette/
+ https://pypi.org/project/plette/
+"
+# pypi tarballs are missing test data
+SRC_URI="
+ https://github.com/sarugaku/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ dev-python/cerberus[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest