summaryrefslogtreecommitdiff
path: root/dev-python/pivy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pivy')
-rw-r--r--dev-python/pivy/Manifest4
-rw-r--r--dev-python/pivy/files/pivy-0.6.4-find-SoQt.patch31
-rw-r--r--dev-python/pivy/metadata.xml23
-rw-r--r--dev-python/pivy/pivy-0.6.5.ebuild41
4 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/pivy/Manifest b/dev-python/pivy/Manifest
new file mode 100644
index 000000000000..e44449dc59d7
--- /dev/null
+++ b/dev-python/pivy/Manifest
@@ -0,0 +1,4 @@
+AUX pivy-0.6.4-find-SoQt.patch 925 BLAKE2B fe3224f5aa0286204e81352b0e6c331654eb15fc509a219a4924cedafebda305182882c2de51aef504ae9a0432beeb4a67c5f80aafc24dab7a40c3a3d37c34dd SHA512 02a9c530759901488073bfa69c7a97d3814d4daa94f4724158ce037e208016f2fd025ac5020717ed80e5f561721d5be6967f0f44521738248f492fd11b7044f8
+DIST pivy-0.6.5.tar.gz 6614159 BLAKE2B 2652feb26137b2deda8b76083d3bd9018303ca0a0236ea97e83e9ff24ddeda30462a25ac1b20b0d3e718fc9f83ae5ebf7116a5c0d94debcc5b6d729792230655 SHA512 6cf0b1ac348336609f42f6a72df7ffdc3e1042a4f8fc6e2b725ca38f09476c70bafa14c1f083d1badeb5b37b974a0fbf5806ea71d44d734b9ab9b125ce7f8695
+EBUILD pivy-0.6.5.ebuild 853 BLAKE2B b56eaee6b4fce45eb8688c9f2635fe95d8362b3ed8b71773c39354a7b2cd3700df7cc9784ba788d66edd9718a11f86ca16ea49bb04cfa711bf08212868332619 SHA512 a36aad7c39ff1658e27d4df282159acc26e5e84e7ef3a634b81d1bea3752527f6d37979576daa764862e988ac2a7dabd2f3a3563bcfad43693059641fc28382e
+MISC metadata.xml 596 BLAKE2B df27b3b1e613d1247245734dc11b084e5b2824108adb8c0f9523150788d46299d05866f6e46aa24172685470153183eb24b7c34a5d22ac1ecf20e424a2fd05a9 SHA512 2dde309132022ae5e7c054f257de8aa43c8fd92f2be8f0a420f8df101e48a3525a35f0d6791d97bc6a905ae071cde9f6052337244c0df6ca782fada9c6a69512
diff --git a/dev-python/pivy/files/pivy-0.6.4-find-SoQt.patch b/dev-python/pivy/files/pivy-0.6.4-find-SoQt.patch
new file mode 100644
index 000000000000..4d8a6fdd8889
--- /dev/null
+++ b/dev-python/pivy/files/pivy-0.6.4-find-SoQt.patch
@@ -0,0 +1,31 @@
+From 1c9ffef4d85327fe517bdcf7e11c339a4862ba2e Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Wed, 12 Jun 2019 21:21:34 +0200
+Subject: [PATCH] CMakeLists.txt: remove NONE keyword for languages from
+ project definition. This solves a bug where SoQt is not found on Gentoo
+ systems (see https://github.com/waebbl/waebbl-gentoo/issues/42)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Thanks to QÍN Yuhào for coming up with this fix.
+
+Suggested-by: QÍN Yuhào <qinyh18@mails.tsinghua.edu.cn>
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 76d0d06..48bd3c0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-project(pivy_cmake_setup NONE)
++project(pivy_cmake_setup)
+ cmake_minimum_required(VERSION 3.5)
+
+
+--
+2.21.0
+
diff --git a/dev-python/pivy/metadata.xml b/dev-python/pivy/metadata.xml
new file mode 100644
index 000000000000..65acee7c3687
--- /dev/null
+++ b/dev-python/pivy/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>fordfrog@gentoo.org</email>
+ <name>Miroslav Šulc</name>
+</maintainer>
+<maintainer type="person">
+ <email>waebbl@gmail.com</email>
+ <name>Bernd Waibel</name>
+</maintainer>
+<use>
+ <flag name="quarter">
+ Use <pkg>media-libs/quarter</pkg> for GUI bindings
+ </flag>
+ <flag name="soqt">
+ Use <pkg>media-libs/SoQt</pkg> for GUI bindings
+ </flag>
+</use>
+<upstream>
+ <remote-id type="github">coin3d/pivy</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/pivy/pivy-0.6.5.ebuild b/dev-python/pivy/pivy-0.6.5.ebuild
new file mode 100644
index 000000000000..0afc6efa7ab1
--- /dev/null
+++ b/dev-python/pivy/pivy-0.6.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Coin3D bindings for Python"
+HOMEPAGE="https://github.com/coin3d/pivy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ PIVY_REPO_URI="https://github.com/coin3d/pivy.git"
+else
+ SRC_URI="https://github.com/coin3d/pivy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="+quarter soqt"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( quarter soqt )
+"
+
+RDEPEND="
+ >=media-libs/coin-4.0.0
+ quarter? ( media-libs/quarter )
+ soqt? ( >=media-libs/SoQt-1.6.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/swig"
+
+PATCHES=( "${FILESDIR}/${PN}-0.6.4-find-SoQt.patch" )
+
+DOCS=( AUTHORS HACKING NEWS README.md THANKS )