summaryrefslogtreecommitdiff
path: root/dev-python/pipenv/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pipenv/files')
-rw-r--r--dev-python/pipenv/files/pipenv-2022.9.24-inject-site-packages.patch34
-rw-r--r--dev-python/pipenv/files/pipenv-2023.4.29-append-always-install.patch19
-rw-r--r--dev-python/pipenv/files/pipenv-2023.7.11-fix-imports-utils.patch15
-rw-r--r--dev-python/pipenv/files/pipenv-2023.7.11-fix-imports.patch39
4 files changed, 0 insertions, 107 deletions
diff --git a/dev-python/pipenv/files/pipenv-2022.9.24-inject-site-packages.patch b/dev-python/pipenv/files/pipenv-2022.9.24-inject-site-packages.patch
deleted file mode 100644
index 04cf0ed9e317..000000000000
--- a/dev-python/pipenv/files/pipenv-2022.9.24-inject-site-packages.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff --git a/pipenv/patched/pip/__main__.py b/pipenv/patched/pip/__main__.py
-index b424ab20..79d52838 100644
---- a/pipenv/patched/pip/__main__.py
-+++ b/pipenv/patched/pip/__main__.py
-@@ -28,6 +28,13 @@ if __name__ == "__main__":
- )
- import importlib.util
- import sys
-+
-+
-+ SITE_PACKAGES_ROOT = os.path.dirname(os.path.dirname(os.path.dirname(os.path.dirname(__file__))))
-+
-+ # Inject site directory into system path.
-+ sys.path.insert(-1, SITE_PACKAGES_ROOT)
-+
- spec = importlib.util.spec_from_file_location(
- "pipenv", location=os.path.join(os.path.dirname(os.path.dirname(os.path.dirname(__file__))), "__init__.py"))
- pipenv = importlib.util.module_from_spec(spec)
-diff --git a/pipenv/resolver.py b/pipenv/resolver.py
-index 3fea0a1e..a0d9da29 100644
---- a/pipenv/resolver.py
-+++ b/pipenv/resolver.py
-@@ -6,6 +6,11 @@ import sys
-
- os.environ["PIP_PYTHON_PATH"] = str(sys.executable)
-
-+SITE_PACKAGES_ROOT = os.path.dirname(os.path.dirname(__file__))
-+
-+# Inject site directory into system path.
-+sys.path.insert(-1, SITE_PACKAGES_ROOT)
-+
-
- def _ensure_modules():
- spec = importlib.util.spec_from_file_location(
diff --git a/dev-python/pipenv/files/pipenv-2023.4.29-append-always-install.patch b/dev-python/pipenv/files/pipenv-2023.4.29-append-always-install.patch
deleted file mode 100644
index 25a9c604e5b4..000000000000
--- a/dev-python/pipenv/files/pipenv-2023.4.29-append-always-install.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/pipenv/routines/install.py b/pipenv/routines/install.py
-index 4b8b2bf8c..a3e1fbcf7 100644
---- a/pipenv/routines/install.py
-+++ b/pipenv/routines/install.py
-@@ -580,6 +580,14 @@ def batch_install_iteration(
- strip_extras_markers_from_requirement,
- )
-
-+ # Gentoo patch:
-+ # Install dependencies into the venv even if they exist
-+ # in the system.
-+ # This is needed because pipenv imports the system packages to run.
-+ # It does not change your system's packages.
-+ if (extra_pip_args is not None) and ("-I" not in extra_pip_args):
-+ extra_pip_args.append("-I")
-+
- is_artifact = False
- for dep in deps_to_install:
- if dep.req.req:
diff --git a/dev-python/pipenv/files/pipenv-2023.7.11-fix-imports-utils.patch b/dev-python/pipenv/files/pipenv-2023.7.11-fix-imports-utils.patch
deleted file mode 100644
index 2e348bf8e440..000000000000
--- a/dev-python/pipenv/files/pipenv-2023.7.11-fix-imports-utils.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/pipenv/utils/environment.py b/pipenv/utils/environment.py
-index 2e066eef2..219d8f9e5 100644
---- a/pipenv/utils/environment.py
-+++ b/pipenv/utils/environment.py
-@@ -1,7 +1,9 @@
- import os
-
-+import click
-+import dotenv
-+
- from pipenv import environments
--from pipenv.vendor import click, dotenv
-
-
- def load_dot_env(project, as_dict=False, quiet=False):
diff --git a/dev-python/pipenv/files/pipenv-2023.7.11-fix-imports.patch b/dev-python/pipenv/files/pipenv-2023.7.11-fix-imports.patch
deleted file mode 100644
index a437d55b6964..000000000000
--- a/dev-python/pipenv/files/pipenv-2023.7.11-fix-imports.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/pipenv/environment.py b/pipenv/environment.py
-index dbb89b011..89f2aaf9e 100644
---- a/pipenv/environment.py
-+++ b/pipenv/environment.py
-@@ -14,7 +14,9 @@ from sysconfig import get_paths, get_python_version, get_scheme_names
- from urllib.parse import urlparse
- from urllib.request import url2pathname
-
-+import click
- import pipenv
-+
- from pipenv.patched.pip._internal.commands.install import InstallCommand
- from pipenv.patched.pip._internal.index.package_finder import PackageFinder
- from pipenv.patched.pip._vendor import pkg_resources
-@@ -23,7 +25,6 @@ from pipenv.utils.funktools import chunked, unnest
- from pipenv.utils.indexes import prepare_pip_source_args
- from pipenv.utils.processes import subprocess_run
- from pipenv.utils.shell import make_posix
--from pipenv.vendor import click
- from pipenv.vendor.pythonfinder.utils import is_in_path
- from pipenv.vendor.requirementslib.fileutils import normalize_path, temp_path
- from pipenv.vendor.requirementslib.utils import temp_environ
-diff --git a/pipenv/project.py b/pipenv/project.py
-index f865988b9..e8714ef63 100644
---- a/pipenv/project.py
-+++ b/pipenv/project.py
-@@ -44,9 +44,11 @@ from pipenv.utils.shell import (
- system_which,
- )
- from pipenv.utils.toml import cleanup_toml, convert_toml_outline_tables
--from pipenv.vendor import click, plette, tomlkit
-+from pipenv.vendor import plette
- from pipenv.vendor.requirementslib.models.utils import get_default_pyproject_backend
-
-+import click, tomlkit
-+
- try:
- # this is only in Python3.8 and later
- from functools import cached_property