summaryrefslogtreecommitdiff
path: root/dev-python/pipdeptree
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pipdeptree')
-rw-r--r--dev-python/pipdeptree/Manifest2
-rw-r--r--dev-python/pipdeptree/pipdeptree-2.16.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pipdeptree/Manifest b/dev-python/pipdeptree/Manifest
index a5903d958253..b643674dda38 100644
--- a/dev-python/pipdeptree/Manifest
+++ b/dev-python/pipdeptree/Manifest
@@ -1,5 +1,7 @@
AUX pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch 1018 BLAKE2B 18405bf1f1ba5a457c9643738258df5d1c3d5ed709954dd274560ae9cbf139f336b75b2c896d9d8bdfe24c4d2cb98ea3e0391d73ac05ba1e38766f2cfa04a431 SHA512 da732fe18cc3f49ed3994133e8a5eefe4c6f8ebf18dad3caeb057bcdbab38f5936c245271d6ff534f3cb6069255e13291a9033594148e70e486fd85d5b9e711e
AUX pipdeptree-2.13.2-fix-pypy-7.3.14.patch 1353 BLAKE2B 5e3a6f53244de1ae185818e3e2a37a87229b46b02c390a606b65668ae1dc53fe1a6b5e6c9faaf6160f25adc7e2597cceb5fd89bb20414a609880e034c7bdc026 SHA512 e0e8e729d713d347c96ee7db5e6a14ba7a9a986aa41231731973b4ab31f8d866cd4d229b35b54411e171a446d61201675ab3df01a58079786eabf5a080de05ad
DIST pipdeptree-2.15.1.tar.gz 34461 BLAKE2B e437785e609bacc31b5ca32fd03b7d69c3b0f597725d021ef978d49037e0d9e6e6b0c6545f5c7a93b4a26befa019156156d554e2d3470282758ed535097377f9 SHA512 ed8482c811758fc94adf196315f022cc6a07029ece9246bab04a64949faa22fc9b6811dd357d0a51803f305c837d6fa1267cf38d5a5cd728c3bf00e65d46d05d
+DIST pipdeptree-2.16.0.tar.gz 34872 BLAKE2B 91401cf9ac05e365332956b874b17b40c62a8a6573b69adeae1d451d2878e887ee180239926962a2b7caae67b45619f715f8ade5c9df5b13683f167ee6592d0e SHA512 c3c1d6377cd3a30980c36fc4935f4aa4b96c402f09017f6e9e3d1c12c56580b1f56b1ea0edcbd6b588dbb96a9f5afa7a727c83faaf110d4a5e7f51df36628a03
EBUILD pipdeptree-2.15.1.ebuild 1001 BLAKE2B 353933b6854bcd9f62299cc3932e5256028cacf9dc5a62c6cbfb546524b4553c8c860c3f43fc9f819dbc89c0ed0a82d63762b6624d8388aace92fd79563e6ff2 SHA512 0c497bfee60c2ae4aa8d11d347190d180630e2753c20f8d8f93546de184fa165738dd7fb52554ca09d0d7a9c70bca060529ef943cf91f07483827749d335ca88
+EBUILD pipdeptree-2.16.0.ebuild 1296 BLAKE2B a3f346c74f7f876c72806b0172fbec559ca737e35406c9aa9971587fa7e1024650c2b652d2d78437c30072b83fa1736e9b08d682575776bf69f9efd6e80092c8 SHA512 6a70a9d9a72f88cdfd39ac52a43659334f57729780eb3a29f827b6db79419451d36995bd7421026d4e235e7f2a0e018f7ba9498c186b402d7f84e2e9f321828a
MISC metadata.xml 545 BLAKE2B cf435473fd95ac0a5bafe2b52ddd78e09c16eb190e3a979924525607fc7ab152e249419e3a21d246cd1354a714116c6c0953ed55d1efceafae441ee282c2b1eb SHA512 ad2e8d4e7bac53b26ea0bb5c2f65e0c9dc8d30afc8c569d73bac820b2dda6a343b96e52abd0353e3f50269fb431e46bd3b51b3768d9c24f658fd2eca6cc1ce97
diff --git a/dev-python/pipdeptree/pipdeptree-2.16.0.ebuild b/dev-python/pipdeptree/pipdeptree-2.16.0.ebuild
new file mode 100644
index 000000000000..8c26d7357bda
--- /dev/null
+++ b/dev-python/pipdeptree/pipdeptree-2.16.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="Utility for displaying installed packages in a dependency tree"
+HOMEPAGE="
+ https://github.com/tox-dev/pipdeptree/
+ https://pypi.org/project/pipdeptree/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # https://github.com/tox-dev/pipdeptree/pull/302
+ "${FILESDIR}/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch"
+ "${FILESDIR}/pipdeptree-2.13.2-fix-pypy-7.3.14.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken when flufl.lock is actually installed
+ # https://github.com/tox-dev/pipdeptree/issues/326
+ tests/_models/test_dag.py::test_package_dag_from_pkgs_uses_pep503normalize
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock
+}
+
+pkg_postinst() {
+ optfeature \
+ "visualising the dependency graph with --graph-output" \
+ dev-python/graphviz
+}