summaryrefslogtreecommitdiff
path: root/dev-python/picklemagic
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/picklemagic')
-rw-r--r--dev-python/picklemagic/Manifest3
-rw-r--r--dev-python/picklemagic/metadata.xml21
-rw-r--r--dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild30
3 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/picklemagic/Manifest b/dev-python/picklemagic/Manifest
deleted file mode 100644
index e4db1d82c71d..000000000000
--- a/dev-python/picklemagic/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST picklemagic-0.0_pre20160415.tar.xz 23364 BLAKE2B 07104393d41c68fabb26d642b6a78b5b5506322edc1322f6a0957c485c2681aafb388488b4d65d920102fb56839ebdeb82cbde909dae3d982311a3d776ca8aca SHA512 0b0866895df5f5f49462d75ad6a435f93796c60eae2442350ea0768872cc1938406b68f5ecb54e1583c245c6ac6d4feada32469184e24186adf78d002adfcd76
-EBUILD picklemagic-0.0_pre20160415.ebuild 667 BLAKE2B 4ebf7c01ee9dd5303a6f4f097872fa20b1b441373a5e58456f1b96d288110601f44611ce228362319fe23ac5276188170f86d57d1dd874b4359d4acc6edee2c3 SHA512 624830cca975da694f501a10ed20c7c7eccde3aa003d3a200a6743581423a9165b4e8180edbe9053c24006f71e62b73a00cd9d0a9eaeed68d3be73f2dd6d02d4
-MISC metadata.xml 1090 BLAKE2B 1f40f412683b97396e9ff6257d33a9f754b3a3e5e03c409c1f3a6a7640d6fd9bf2688ef6e79603023dfbc283a439ac3a5f4e201a36c9692171e0a58ae60fbfae SHA512 474903af747e9b60d4b5440190045c4a0f0fe54bc8436c40c9c4b2186025d246c173ca6bfe80cc966f5e843d469fea852251d142266661490d6a0f6b8dd84a1c
diff --git a/dev-python/picklemagic/metadata.xml b/dev-python/picklemagic/metadata.xml
deleted file mode 100644
index fd5c1e286b51..000000000000
--- a/dev-python/picklemagic/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>bircoph@gentoo.org</email>
- <name>Andrew Savchenko</name>
- </maintainer>
- <longdescription>
- A set of modules for analyzing and playing with the mechanics of python pickles.
- Features:
- * Forgiving: Extracts as much data as possible from the pickle, even if class definitions are unavailable.
- * Safe: You can safely unpickle data structures from unknown sources
- * Easy to use: Tools are provided which make it possible to code around the unpickled datastructures as if they were created from the actual class definitions.
- * Customizeable: Most functionality is easily subclassable to suit your needs.
- * Create pickles as if you were writing python: Via a few constructs it's possible to create custom pickles with the ease of writing normal python.
- * Works in both python 2 and 3
- </longdescription>
- <upstream>
- <remote-id type="github">CensoredUsername/picklemagic</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild b/dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild
deleted file mode 100644
index 62aedd757fa9..000000000000
--- a/dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-inherit python-r1
-
-DESCRIPTION="A library for analysing python pickles safely"
-HOMEPAGE="https://github.com/CensoredUsername/picklemagic"
-SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
-
-LICENSE="WTFPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-BDEPEND="doc? ( dev-python/sphinx )"
-RDEPEND="${PYTHON_DEPS}"
-
-src_compile() {
- use doc && emake -C doc html
-}
-
-src_install() {
- default
- python_foreach_impl python_domodule *.py
- use doc && dodoc -r doc/build/html
-}