summaryrefslogtreecommitdiff
path: root/dev-python/pgmagick/pgmagick-0.6.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pgmagick/pgmagick-0.6.7.ebuild')
-rw-r--r--dev-python/pgmagick/pgmagick-0.6.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pgmagick/pgmagick-0.6.7.ebuild b/dev-python/pgmagick/pgmagick-0.6.7.ebuild
new file mode 100644
index 000000000000..7e33e5a5ae01
--- /dev/null
+++ b/dev-python/pgmagick/pgmagick-0.6.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another boost.python based wrapper for GraphicsMagick"
+HOMEPAGE="https://pypi.python.org/pypi/pgmagick/ https://bitbucket.org/hhatto/pgmagick/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ media-gfx/graphicsmagick:=[cxx]
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( media-fonts/corefonts )"
+
+python_test() {
+ cd test || die
+
+ local t
+ for t in test_*.py; do
+ "${EPYTHON}" "${t}" || die "test ${t} failed under ${EPYTHON}"
+ done
+ # As long as the order of python impls is not changed, this will suffice
+}