summaryrefslogtreecommitdiff
path: root/dev-python/pgasync/pgasync-2.01-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pgasync/pgasync-2.01-r1.ebuild')
-rw-r--r--dev-python/pgasync/pgasync-2.01-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pgasync/pgasync-2.01-r1.ebuild b/dev-python/pgasync/pgasync-2.01-r1.ebuild
new file mode 100644
index 000000000000..272afddb3b93
--- /dev/null
+++ b/dev-python/pgasync/pgasync-2.01-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="An asynchronous API to PostgreSQL for twisted"
+HOMEPAGE="https://github.com/jamwt/pgasync"
+SRC_URI="http://www.jamwt.com/pgasync/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+DEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGELOG PKG-INFO README TODO"
+
+src_install() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}