summaryrefslogtreecommitdiff
path: root/dev-python/pexpect
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/Manifest3
-rw-r--r--dev-python/pexpect/files/pexpect-4.8.0-sphinx-3.patch25
-rw-r--r--dev-python/pexpect/pexpect-4.8.0.ebuild49
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/pexpect/Manifest b/dev-python/pexpect/Manifest
index 5071bd76dee9..415399cfd3ec 100644
--- a/dev-python/pexpect/Manifest
+++ b/dev-python/pexpect/Manifest
@@ -1,3 +1,6 @@
+AUX pexpect-4.8.0-sphinx-3.patch 761 BLAKE2B 609849b3587cd5eeada58ba5065111f3d5d38514d525c49682a9554fe5b21c4b5994ad3cc70725c1a73e19daf03c66644a7fa0ac880d87e912620263396df3d9 SHA512 d6cd0c3554c83c0092f46a2254dbe1752773abd76c220e0eeecd4a416f01ec57ecd51f26011e17d03537746d24f913472467d9ac8b569bdc168b6975292b4cab
DIST pexpect-4.6.0.tar.gz 148966 BLAKE2B 0ed1a3c31133bf618e4c75ea099efaa9bda9e2b7f92f46c54ad553ecc56487e5415b750334376a95599ada53e17e91efe7d4b65ad80bb4f6a1cf9d655a3c9685 SHA512 9a2b1ef19d885e69cfd17ba0519581f782574019010043e66d8b68f98ac86b359f4a1ca42f8bb0059a5dfdd43275ad93531c076cc0ac2049e109408961b46bbd
+DIST pexpect-4.8.0.tar.gz 157037 BLAKE2B 742642bd6b9ec3f6cdfad054d4fd22db56b4a55b746d675c27a8cdf824ea749ec4589e296dffa08778195f3ccd20feb56bc0fd5212984396ea5aa0555c41ca96 SHA512 7447ae2d1e13be422c894a8fd51c5aaa788e37ea7f0c798c88b77afd401fb3631400a637077ccbb83c2e3876b0d0c5e1dbd5fdc9d3739d785b4d5ad7c0192580
EBUILD pexpect-4.6.0.ebuild 1035 BLAKE2B 96382c648071656d317e9a12a6c75c2290d6753b9bb1166f2f1c3005b10ec13eed9dece1fdb4d67369aebb2d4441e27261d417750d93a668a527b1ab241e6c82 SHA512 cd2feb6f32b22c1125cd7c58e21b5ac3ddfe953d73eb0d3ca6dd98df768257c60afc2bc1519a5468137c2c44e58a50b444c9d13850273434304d163ee5cfbd33
+EBUILD pexpect-4.8.0.ebuild 1269 BLAKE2B ee68be8eb70cc4526c50e75cf0e3793a9ee1be5e6df878bc7db517bd584d5b1587d83a7becbf7dd69cd59654743d98b465428247b86a56c1514965148b5b0cc0 SHA512 ef1a8b0bfd0c526a64b1305fe48a8f41c032395002909554e913d5ef50469e84efa2d1e92a3aeac598cf9cefbdbcae5507b6bdf581d9859b70089b697539f8be
MISC metadata.xml 377 BLAKE2B 72c4b35c12a770df9344987af8c7a392c3aed05296a4876902987ef946239f8318ee833cc81a7f004719e954670a83e84a3813bcdaac48912efad885515de1ea SHA512 31e65b2ce9ec12e9d3e95ed651841b8aad6a24330fe20b4bfd6351267423ff5005ac3cb2e89dbb8f024cf60705d3f06a8a1309169a029eb5246ddc45a8d76464
diff --git a/dev-python/pexpect/files/pexpect-4.8.0-sphinx-3.patch b/dev-python/pexpect/files/pexpect-4.8.0-sphinx-3.patch
new file mode 100644
index 000000000000..d23055fba251
--- /dev/null
+++ b/dev-python/pexpect/files/pexpect-4.8.0-sphinx-3.patch
@@ -0,0 +1,25 @@
+From 506bcd97fa1d20d1412d399353c38f0ff3546a1a Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 13 Apr 2020 23:26:09 +0200
+Subject: [PATCH] Fix compilation of docs with Sphinx 3.0.1
+
+https://github.com/pexpect/pexpect/issues/637
+---
+ doc/sphinxext/github.py | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/doc/sphinxext/github.py b/doc/sphinxext/github.py
+index 519e146..771dccc 100644
+--- a/doc/sphinxext/github.py
++++ b/doc/sphinxext/github.py
+@@ -146,7 +146,6 @@ def setup(app):
+
+ :param app: Sphinx application context.
+ """
+- app.info('Initializing GitHub plugin')
+ app.add_role('ghissue', ghissue_role)
+ app.add_role('ghpull', ghissue_role)
+ app.add_role('ghuser', ghuser_role)
+--
+2.26.0
+
diff --git a/dev-python/pexpect/pexpect-4.8.0.ebuild b/dev-python/pexpect/pexpect-4.8.0.ebuild
new file mode 100644
index 000000000000..076cdb78ac2c
--- /dev/null
+++ b/dev-python/pexpect/pexpect-4.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for spawning child apps and responding to expected patterns"
+HOMEPAGE="https://pexpect.readthedocs.io/ https://pypi.org/project/pexpect/ https://github.com/pexpect/pexpect/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples"
+
+RDEPEND=">=dev-python/ptyprocess-0.5[${PYTHON_USEDEP}]"
+DEPEND="
+ doc? ( dev-python/sphinx )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sphinx-3.patch
+)
+
+distutils_enable_tests pytest
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! python_is_python3; then
+ # https://bugs.gentoo.org/703100
+ rm "${D}$(python_get_sitedir)/pexpect/_async.py" || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}