summaryrefslogtreecommitdiff
path: root/dev-python/pefile/pefile-2024.8.26.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pefile/pefile-2024.8.26.ebuild')
-rw-r--r--dev-python/pefile/pefile-2024.8.26.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pefile/pefile-2024.8.26.ebuild b/dev-python/pefile/pefile-2024.8.26.ebuild
new file mode 100644
index 000000000000..5e1d6ab44aa8
--- /dev/null
+++ b/dev-python/pefile/pefile-2024.8.26.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Module to read and work with Portable Executable (PE) files"
+HOMEPAGE="https://github.com/erocarrera/pefile"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/erocarrera/pefile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/erocarrera/pefile/releases/download/v${PV}/${P}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+# Unfortunately there is nothing we can test here. Upstream doesn't ship a test
+# suite inside the release files. The test fixtures in the source repo is
+# encrypted so that only their CI pipeline is able to run the tests.
+RESTRICT="test"