summaryrefslogtreecommitdiff
path: root/dev-python/peewee/peewee-3.15.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/peewee/peewee-3.15.0.ebuild')
-rw-r--r--dev-python/peewee/peewee-3.15.0.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/peewee/peewee-3.15.0.ebuild b/dev-python/peewee/peewee-3.15.0.ebuild
deleted file mode 100644
index 07b7c4995d4d..000000000000
--- a/dev-python/peewee/peewee-3.15.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="Small Python ORM"
-HOMEPAGE="
- https://github.com/coleifer/peewee/
- https://pypi.org/project/peewee/
-"
-SRC_URI="
- https://github.com/coleifer/${PN}/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs
-
-python_test() {
- "${EPYTHON}" runtests.py -v 2 || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && DOCS=( examples/ )
- distutils-r1_python_install_all
-}