summaryrefslogtreecommitdiff
path: root/dev-python/pdoc3/pdoc3-0.9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pdoc3/pdoc3-0.9.2.ebuild')
-rw-r--r--dev-python/pdoc3/pdoc3-0.9.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pdoc3/pdoc3-0.9.2.ebuild b/dev-python/pdoc3/pdoc3-0.9.2.ebuild
new file mode 100644
index 000000000000..1e67b6da6769
--- /dev/null
+++ b/dev-python/pdoc3/pdoc3-0.9.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Auto-generate API documentation for Python projects"
+HOMEPAGE="https://pdoc3.github.io/pdoc/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="AGPL-3+"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i \
+ -e "/setuptools_git/d" \
+ -e "/setuptools_scm/d" \
+ setup.py || die
+}