summaryrefslogtreecommitdiff
path: root/dev-python/pdoc3/pdoc3-0.10.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pdoc3/pdoc3-0.10.0-r2.ebuild')
-rw-r--r--dev-python/pdoc3/pdoc3-0.10.0-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pdoc3/pdoc3-0.10.0-r2.ebuild b/dev-python/pdoc3/pdoc3-0.10.0-r2.ebuild
new file mode 100644
index 000000000000..b118fab9f094
--- /dev/null
+++ b/dev-python/pdoc3/pdoc3-0.10.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Auto-generate API documentation for Python projects"
+HOMEPAGE="https://pdoc3.github.io/pdoc/"
+SRC_URI+="
+ https://github.com/pdoc3/pdoc/commit/14cd51c1b7431cdec5c3e7510b8a0e3b66c2f7d4.patch
+ -> ${PN}-0.10.0-fix-deprecation-warnings.patch
+"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-TST-use-explicit-ClassWithNew-instead-of-typing.Gene.patch"
+ "${FILESDIR}/${PN}-0.10.0-update-tests.patch"
+ "${DISTDIR}"/${PN}-0.10.0-fix-deprecation-warnings.patch
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i \
+ -e "/setuptools_git/d" \
+ -e "/setuptools_scm/d" \
+ setup.py || die
+}
+
+distutils_enable_tests unittest