summaryrefslogtreecommitdiff
path: root/dev-python/pcapy/pcapy-0.11.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pcapy/pcapy-0.11.2.ebuild')
-rw-r--r--dev-python/pcapy/pcapy-0.11.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pcapy/pcapy-0.11.2.ebuild b/dev-python/pcapy/pcapy-0.11.2.ebuild
new file mode 100644
index 000000000000..78a8a1c5989d
--- /dev/null
+++ b/dev-python/pcapy/pcapy-0.11.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python pcap extension"
+HOMEPAGE="https://www.coresecurity.com/corelabs-research/open-source-tools/pcapy"
+SRC_URI="https://github.com/CoreSecurity/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="${DEPEND}
+net-libs/libpcap"
+
+python_test() {
+ cd "${S}/tests" || die "Unable to activate test suite"
+ "${EPYTHON}" pcapytests.py || die "Tests failed with ${EPYTHON}"
+}