summaryrefslogtreecommitdiff
path: root/dev-python/pbs-installer/pbs-installer-2024.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pbs-installer/pbs-installer-2024.4.1.ebuild')
-rw-r--r--dev-python/pbs-installer/pbs-installer-2024.4.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pbs-installer/pbs-installer-2024.4.1.ebuild b/dev-python/pbs-installer/pbs-installer-2024.4.1.ebuild
new file mode 100644
index 000000000000..dfe012214833
--- /dev/null
+++ b/dev-python/pbs-installer/pbs-installer-2024.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="Installer for Python Build Standalone"
+HOMEPAGE="
+ https://pypi.org/project/pbs-installer/
+ https://github.com/frostming/pbs-installer/
+
+"
+SRC_URI="https://github.com/frostming/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/zstandard[${PYTHON_USEDEP}]
+"
+
+# upstream does not provide any tests
+RESTRICT=test
+
+python_configure_all() {
+ export PDM_BUILD_SCM_VERSION=${PV}
+}