summaryrefslogtreecommitdiff
path: root/dev-python/pbr/pbr-5.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pbr/pbr-5.1.1.ebuild')
-rw-r--r--dev-python/pbr/pbr-5.1.1.ebuild47
1 files changed, 27 insertions, 20 deletions
diff --git a/dev-python/pbr/pbr-5.1.1.ebuild b/dev-python/pbr/pbr-5.1.1.ebuild
index 79cab5d13d39..4ca2cfcd1915 100644
--- a/dev-python/pbr/pbr-5.1.1.ebuild
+++ b/dev-python/pbr/pbr-5.1.1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~hppa ~mips ~s390 ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm64 ~hppa ~mips ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
@@ -22,29 +22,30 @@ RESTRICT="!test? ( test )"
# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+# stestr is run as external tool
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-14.0.6[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
- >=dev-python/stestr-2.1.0[${PYTHON_USEDEP}]
- ' python{2_7,3_5,3_6,3_7})
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-vcs/git
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-14.0.6[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.1.0
+ dev-vcs/git
+ ' -3)
)"
PDEPEND=""
@@ -70,6 +71,12 @@ python_prepare_all() {
}
python_test() {
+ if ! python_is_python3; then
+ ewarn "Skipping tests on ${EPYTHON} to unblock circular deps."
+ ewarn "Please run tests manually."
+ return
+ fi
+
distutils_install_for_testing
rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"