summaryrefslogtreecommitdiff
path: root/dev-python/patsy/patsy-0.5.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/patsy/patsy-0.5.5.ebuild')
-rw-r--r--dev-python/patsy/patsy-0.5.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/patsy/patsy-0.5.5.ebuild b/dev-python/patsy/patsy-0.5.5.ebuild
new file mode 100644
index 000000000000..d2134e279146
--- /dev/null
+++ b/dev-python/patsy/patsy-0.5.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="
+ https://patsy.readthedocs.io/en/latest/index.html
+ https://github.com/pydata/patsy/
+ https://pypi.org/project/patsy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !hppa? (
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest