summaryrefslogtreecommitdiff
path: root/dev-python/patch-ng/patch-ng-1.17.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/patch-ng/patch-ng-1.17.4.ebuild')
-rw-r--r--dev-python/patch-ng/patch-ng-1.17.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/patch-ng/patch-ng-1.17.4.ebuild b/dev-python/patch-ng/patch-ng-1.17.4.ebuild
new file mode 100644
index 000000000000..39e7235c4fa4
--- /dev/null
+++ b/dev-python/patch-ng/patch-ng-1.17.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Library to parse and apply unified diffs, fork of dev-python/patch"
+HOMEPAGE="https://github.com/conan-io/python-patch-ng https://pypi.org/project/patch-ng/"
+SRC_URI="https://github.com/conan-io/python-patch-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest
+
+S="${WORKDIR}/python-${P}"
+
+python_test() {
+ "${EPYTHON}" -m unittest tests/run_tests.py || die "Tests failed under ${EPYTHON}"
+}