summaryrefslogtreecommitdiff
path: root/dev-python/partd/partd-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/partd/partd-1.2.0.ebuild')
-rw-r--r--dev-python/partd/partd-1.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/partd/partd-1.2.0.ebuild b/dev-python/partd/partd-1.2.0.ebuild
new file mode 100644
index 000000000000..91a5db4fd7ca
--- /dev/null
+++ b/dev-python/partd/partd-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Appendable key-value storage"
+HOMEPAGE="https://github.com/dask/partd/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/locket[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/blosc[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest