summaryrefslogtreecommitdiff
path: root/dev-python/paramiko
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/paramiko')
-rw-r--r--dev-python/paramiko/Manifest2
-rw-r--r--dev-python/paramiko/paramiko-3.4.1.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/paramiko/Manifest b/dev-python/paramiko/Manifest
index 5cee3623731b..8887f80759d6 100644
--- a/dev-python/paramiko/Manifest
+++ b/dev-python/paramiko/Manifest
@@ -2,5 +2,7 @@ AUX paramiko-3.2.0-disable-server.patch 1771 BLAKE2B 3cab494873956d6f36b8ea85903
AUX paramiko-3.2.0-nih-test-deps.patch 4289 BLAKE2B 4a77852f0ae3cda52eca8844f4bf2571c17a0935088973f48c46abf250081845a870fb52d8ebafb108f634dbe86fbe784eefd49d9240c50f911d56173d1e3d71 SHA512 4e0bed394e4c8be19108cc0a7253d6306a698a3cc09b40c18459c8e16591ff42c41cb4f385fc05dcf902161fa23ce2b7d00c665784b9106344a5ca42e4f2a788
AUX paramiko-3.4.0-pytest-fixes.patch 1082 BLAKE2B bf12d79158c9d21c2db43e1e6ea85a5f7d67c97a88f6a0fa76f7bca1a3bf49d59f63dccd278a21a8556465c09676b2941a2ebd07303bcd75141a1d42e5334694 SHA512 338f493ef9e920618acc9351cee5a81303d7ed9dbb98215f5b8621a5bddbea61ebffedcd09991fbc80163c1ecf53433a2e1b4c860b8a4d204eb8b2b039b3b484
DIST paramiko-3.4.0.gh.tar.gz 374441 BLAKE2B a6ea03d40e477cb02c1293c46025909251f8eec2be70638bf850638d9fe8c15bfe0e278697e41f3595f482b8f0755d911b905b11db2324eca597fc9be2a22f24 SHA512 f78fccf653d05acee78dfb76fb662c85fbfea7901fd94460a2d2e526c9b25169993051d20c16cfe0b7745008b1ea3a745fc9a280386d98a06689aaadf78f6752
+DIST paramiko-3.4.1.gh.tar.gz 375155 BLAKE2B 576cc5b23010eaf46eec7dc98e5930c134948038b5588a2cf198289f11a9ab33978e582f273e39d3154fa5fa48109a9bb493745c658e2a2082af055a8f0bc80e SHA512 99026c1045a7f9f4aa7484d089a94dfff141c5d8c565d0bfb3f5c9b1387d963b8f8b3718a79668b1cfe1ec581ab3cb76af787f8011d254aa14c00a5496a805eb
EBUILD paramiko-3.4.0.ebuild 1392 BLAKE2B ffbae7f8e32c8e27329da800215992573720217e079a2cfa43495f53c3fa65cdca33abecb6286a9bb537013ab263310499468b44702670c3d6b97b1775492f16 SHA512 dc50e59d8943e425cffc5f2fc878be9e840465c9a1d9d4aa34d1c6d41c64ae605c2f8d05a6c212771decfc9fad1f67f6d0055912ccd8f3186770e060cb9e426d
+EBUILD paramiko-3.4.1.ebuild 1527 BLAKE2B bf1e7b29d47356488013be45855e37826df5123501629fba79d8f8c743d182d5453cba283cd65b920acfc503e94c64d5f6e9e8198c234ccaa07822f886380fa0 SHA512 298afe9e1833d1916740292c911ee8ba76adf6a4d5c02b0d74c8fd184f96c046b04caba0f1fba6e809598001934f9cde6ba8416dd053fb29b701e043e1c4bcc9
MISC metadata.xml 1222 BLAKE2B 46fb6385f6779cbc13fa54090dd5dfa0b5a7b5a753f728b133fa79a1e1c779a5652d6b38c5ea11cfcb505178b2ba70d9000dabba6228e38f30f426ecb1c49a3f SHA512 bf07a537ed375a3bf58d219c18ccfc29c810554041943e62819a46b63ce3fbcdd2197085dbeeb7ad36e0e601700edec6121ce5cc83dce1c7435d663473df2583
diff --git a/dev-python/paramiko/paramiko-3.4.1.ebuild b/dev-python/paramiko/paramiko-3.4.1.ebuild
new file mode 100644
index 000000000000..a007b925a2af
--- /dev/null
+++ b/dev-python/paramiko/paramiko-3.4.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="SSH2 protocol library"
+HOMEPAGE="
+ https://www.paramiko.org/
+ https://github.com/paramiko/paramiko/
+ https://pypi.org/project/paramiko/
+"
+SRC_URI="
+ https://github.com/paramiko/paramiko/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples server"
+
+RDEPEND="
+ >=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.5[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # upstream doesn't really maintain the gssapi support
+ tests/test_gssapi.py
+ tests/test_kex_gss.py
+ tests/test_ssh_gss.py
+)
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-3.2.0-nih-test-deps.patch"
+ )
+
+ if ! use server; then
+ PATCHES+=( "${FILESDIR}/${PN}-3.2.0-disable-server.patch" )
+ fi
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p rerunfailures --reruns=5
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r demos/*
+ fi
+}