summaryrefslogtreecommitdiff
path: root/dev-python/pandas/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pandas/files')
-rw-r--r--dev-python/pandas/files/pandas-2.1.1-which.patch12
-rw-r--r--dev-python/pandas/files/pandas-2.1.4-khash-dep.patch45
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/pandas/files/pandas-2.1.1-which.patch b/dev-python/pandas/files/pandas-2.1.1-which.patch
deleted file mode 100644
index 424c10af82ae..000000000000
--- a/dev-python/pandas/files/pandas-2.1.1-which.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/pandas/io/clipboard/__init__.py b/pandas/io/clipboard/__init__.py
-index c07f51d875..14d79fb367 100644
---- a/pandas/io/clipboard/__init__.py
-+++ b/pandas/io/clipboard/__init__.py
-@@ -87,6 +87,7 @@ else:
-
-
- def _executable_exists(name):
-+ return which(name)
- return (
- subprocess.call(
- [WHICH_CMD, name], stdout=subprocess.PIPE, stderr=subprocess.PIPE
diff --git a/dev-python/pandas/files/pandas-2.1.4-khash-dep.patch b/dev-python/pandas/files/pandas-2.1.4-khash-dep.patch
deleted file mode 100644
index f8bbff5fed37..000000000000
--- a/dev-python/pandas/files/pandas-2.1.4-khash-dep.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From e31a6865958442435ae9b31f312129c44f66eb5e Mon Sep 17 00:00:00 2001
-From: Ville Aikas <11279988+vaikas@users.noreply.github.com>
-Date: Mon, 6 Nov 2023 09:24:40 -0800
-Subject: [PATCH] Add missing dependencies for: _khash_primitive_helper
- (#55795)
-
-* Add missing dependencies for: _khash_primitive_helper
-
-Signed-off-by: Ville Aikas <vaikas@chainguard.dev>
-
-* source->dep change.
-
-Signed-off-by: Ville Aikas <vaikas@chainguard.dev>
-
-* Remove dep from arrays.
-
-Signed-off-by: Ville Aikas <vaikas@chainguard.dev>
-
----------
-
-Signed-off-by: Ville Aikas <vaikas@chainguard.dev>
----
- pandas/_libs/meson.build | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/pandas/_libs/meson.build b/pandas/_libs/meson.build
-index b4662d6bf8dd2..c27386743c6e9 100644
---- a/pandas/_libs/meson.build
-+++ b/pandas/_libs/meson.build
-@@ -61,12 +61,12 @@ subdir('tslibs')
- libs_sources = {
- # Dict of extension name -> dict of {sources, include_dirs, and deps}
- # numpy include dir is implicitly included
-- 'algos': {'sources': ['algos.pyx', _algos_common_helper, _algos_take_helper, _khash_primitive_helper]},
-+ 'algos': {'sources': ['algos.pyx', _algos_common_helper, _algos_take_helper], 'deps': _khash_primitive_helper_dep},
- 'arrays': {'sources': ['arrays.pyx']},
- 'groupby': {'sources': ['groupby.pyx']},
- 'hashing': {'sources': ['hashing.pyx']},
-- 'hashtable': {'sources': ['hashtable.pyx', _khash_primitive_helper, _hashtable_class_helper, _hashtable_func_helper]},
-- 'index': {'sources': ['index.pyx', _index_class_helper]},
-+ 'hashtable': {'sources': ['hashtable.pyx', _hashtable_class_helper, _hashtable_func_helper], 'deps': _khash_primitive_helper_dep},
-+ 'index': {'sources': ['index.pyx', _index_class_helper], 'deps': _khash_primitive_helper_dep},
- 'indexing': {'sources': ['indexing.pyx']},
- 'internals': {'sources': ['internals.pyx']},
- 'interval': {'sources': ['interval.pyx', _intervaltree_helper],