summaryrefslogtreecommitdiff
path: root/dev-python/pallets-sphinx-themes/pallets-sphinx-themes-2.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pallets-sphinx-themes/pallets-sphinx-themes-2.1.2.ebuild')
-rw-r--r--dev-python/pallets-sphinx-themes/pallets-sphinx-themes-2.1.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pallets-sphinx-themes/pallets-sphinx-themes-2.1.2.ebuild b/dev-python/pallets-sphinx-themes/pallets-sphinx-themes-2.1.2.ebuild
new file mode 100644
index 000000000000..f727d044d1af
--- /dev/null
+++ b/dev-python/pallets-sphinx-themes/pallets-sphinx-themes-2.1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_PN=Pallets-Sphinx-Themes
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx themes for Pallets and related projects"
+HOMEPAGE="
+ https://github.com/pallets/pallets-sphinx-themes/
+ https://pypi.org/project/Pallets-Sphinx-Themes/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-3[${PYTHON_USEDEP}]
+"